IntersectDetail Class
Extends
Methods
Name | Description | |
---|---|---|
draw(context: DecorateContext): void | Draw this HitDetail as a Decoration. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
clone(): SnapDetail Inherited | SnapDetail | Make a copy of this SnapDetail. |
getCurvePrimitive(singleSegment: booleantrue): undefined | CurvePrimitive Inherited | SnapDetail | |
getHitType(): HitDetailType Inherited | SnapDetail | Returns HitDetailType.Snap |
getPoint(): Point3d Inherited | SnapDetail | Get the snap point if this SnapDetail is hot, the pick point otherwise. |
getToolTip(): Promise<string | HTMLElement> Inherited | SnapDetail | Get the tooltip content for this HitDetail. |
isSameHit(otherHit?: HitDetail): boolean Inherited | SnapDetail | Determine if this HitPoint is from the same source as another HitDetail. |
setCurvePrimitive(primitive?: CurvePrimitive, localToWorld?: Transform, geomType?: HitGeomType): void Inherited | SnapDetail | Set curve primitive and HitGeometryType for this SnapDetail. |
setSnapPoint(point: Point3d, heat: SnapHeat): void Inherited | SnapDetail | Change the snap point. |
Properties
Name | Type | Description | |
---|---|---|---|
otherId Readonly | string | ||
otherPrimitive Readonly | CurvePrimitive |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
adjustedPoint Readonly Inherited | Point3d | SnapDetail | AccuSnap/AccuDraw can adjust the point after the snap. |
distFraction Accessor Inherited ReadOnly | number | SnapDetail | The distance in view coordinates between the hit and the near plane. |
distXY Accessor Inherited ReadOnly | number | SnapDetail | The xy distance to the hit in view coordinates. |
geometryClass Accessor Inherited ReadOnly | undefined | GeometryClass | SnapDetail | The class of the hit geometry. |
geomType Inherited | HitGeomType | undefined | SnapDetail | The HitGeomType of this SnapDetail |
heat Inherited | SnapHeat | SnapDetail | The SnapHeat of this SnapDetail |
hitPoint Accessor Inherited ReadOnly | Point3d | SnapDetail | The approximate location in world coordinates on the geometry identified by this HitDetail. |
hitSource Accessor Inherited ReadOnly | HitSource | SnapDetail | The procedure that requested the locate operation. |
iModel Accessor Inherited ReadOnly | IModelConnection | SnapDetail | The IModelConnection from which the hit originated. In some cases this may not be the same as the iModel associated with the Viewport - for example, if a TiledGraphicsProvider is used to display graphics from a different iModel in the viewport. This HitDetail's element, subcategory, and model Ids are defined in the context of this IModelConnection. |
isElementHit Accessor Inherited ReadOnly | boolean | SnapDetail | Return whether sourceId is for a persistent element and not a pickable decoration. |
isExternalIModelHit Accessor Inherited ReadOnly | boolean | SnapDetail | Returns true if this hit originated from an IModelConnection other than the one associated with the Viewport. |
isHot Accessor Inherited ReadOnly | boolean | SnapDetail | Return true if the pick point was closer than the snap aperture from the generated snap point. |
isMapHit Accessor Inherited ReadOnly | boolean | SnapDetail | |
isModelHit Accessor Inherited ReadOnly | boolean | SnapDetail | |
isPointAdjusted Accessor Inherited ReadOnly | boolean | SnapDetail | Determine whether the adjustedPoint is different than the snapPoint. This happens, for example, when points are adjusted for grids, acs plane snap, and AccuDraw. |
modelId Accessor Inherited ReadOnly | undefined | string | SnapDetail | The Id of the ModelState from which the hit originated. |
normal Inherited | Vector3d | undefined | SnapDetail | Surface normal at snapPoint |
parentGeomType Inherited | HitParentGeomType | undefined | SnapDetail | The HitGeomType of this SnapDetail |
path Accessor Inherited ReadOnly | undefined | HitPath | SnapDetail | Describes the path by which the hit was located through a series of attached views. |
primitive Inherited | CurvePrimitive | undefined | SnapDetail | Curve primitive for snap. |
priority Accessor Inherited ReadOnly | HitPriority | SnapDetail | The hit geometry priority/classification. |
snapMode Inherited | SnapMode | SnapDetail | The SnapMode used to create this SnapDetail |
snapPoint Readonly Inherited | Point3d | SnapDetail | HitPoint adjusted by snap |
sourceId Accessor Inherited ReadOnly | string | SnapDetail | The source of the geometry. This may be a persistent element Id, or a transient Id used for, e.g., pickable decorations. |
sprite Inherited | Sprite | undefined | SnapDetail | A sprite to show the user the type of snap performed |
subCategoryId Accessor Inherited ReadOnly | undefined | string | SnapDetail | The SubCategory to which the hit geometry belongs. |
testPoint Accessor Inherited ReadOnly | Point3d | SnapDetail | The point in world coordinates that was used as the initial locate point. |
viewAttachment Accessor Inherited ReadOnly | undefined | ViewAttachmentHitInfo | SnapDetail | Information about the ViewAttachment within which the hit geometry resides, if any. |
viewport Accessor Inherited ReadOnly | ScreenViewport | SnapDetail | The viewport in which the locate operation was performed. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.