TiledGraphicsProvider Namespace
Defined in
TiledGraphicsProvider Interface
Provides a way for applications to inject additional non-decorative graphics into a Viewport by supplying one or more TileTreeReferences capable of loading and drawing the graphics.
@see - addTiledGraphicsProvider to register a provider to be drawn in a viewport.
- Exploded View Sample for an interactive demonstration of a custom provider.
Methods
Name | Description | |
---|---|---|
forEachTileTreeRef(viewport: Viewport, func: (ref: TileTreeReference) => void): void | For each TileTreeReference belonging to this provider that should be drawn in the specified Viewport, apply the provided function. |
Properties
Name | Type | Description | |
---|---|---|---|
addToScene | (context: SceneContext) => void | undefined | If defined, overrides the logic for adding this provider's graphics into the scene. | |
isLoadingComplete | (viewport: Viewport) => boolean | undefined | If defined, returns true if the TileTrees required for displaying this provider's graphics in the specified Viewport are loaded and ready to draw. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.