LightSettings Class
Describes the lighting for a 3d scene, associated with a DisplayStyle3dSettings in turn associated with a DisplayStyle3d or DisplayStyle3dState.
@see LightSettingsProps
Methods
Name | Description | |
---|---|---|
clone(changed?: LightSettingsProps): LightSettings | Create a copy of these light settings, identical except for any properties explicitly specified by changed . |
|
equals(rhs: LightSettings): boolean | ||
toJSON(): undefined | LightSettingsProps | ||
fromJSON(props?: LightSettingsProps): LightSettings Static |
Properties
Name | Type | Description | |
---|---|---|---|
ambient Readonly | AmbientLight | ||
fresnel Readonly | FresnelSettings | ||
hemisphere Readonly | HemisphereLights | ||
numCels Readonly | number | See numCels. | |
portraitIntensity Readonly | number | See portrait. | |
solar Readonly | SolarLight | ||
specularIntensity Readonly | number |
Defined in
- core/common/src/LightSettings.ts Line 426
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.