SolarLight Class
Describes the solar directional light associated with a LightSettings.
@see SolarLightProps.
Methods
Name | Description | |
---|---|---|
constructor(json?: SolarLightProps): SolarLight | ||
clone(changedProps?: SolarLightProps): SolarLight | Create a copy of this SolarLight, identical except in any properties explicitly specified by changedProps , with a possible exception for timePoint. |
|
equals(rhs: SolarLight): boolean | ||
toJSON(): undefined | SolarLightProps |
Properties
Name | Type | Description | |
---|---|---|---|
alwaysEnabled Readonly | boolean | If true, the light will be applied even when shadows are turned off for the view. | |
direction Readonly | Readonly<Vector3d> | Direction of the light in world coordinates. | |
intensity Readonly | number | Intensity of the light, typically in [0..1] but can range up to 5. | |
timePoint Readonly | number | undefined | If defined, the time in UNIX milliseconds from which direction was calculated. |
Defined in
- core/common/src/LightSettings.ts Line 47
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.