AmbientLight Class
Describes the ambient light associated with a LightSettings.
@see AmbientLightProps
Methods
Name | Description | |
---|---|---|
constructor(json?: AmbientLightProps): AmbientLight | ||
clone(changed?: AmbientLightProps): AmbientLight | Create a copy of this light, identical except for any properties explicitly specified by changed . |
|
equals(rhs: AmbientLight): boolean | ||
toJSON(): undefined | AmbientLightProps |
Properties
Name | Type | Description | |
---|---|---|---|
color Readonly | RgbColor | ||
intensity Readonly | number |
Defined in
- core/common/src/LightSettings.ts Line 154
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.