LightSettingsProps Interface
Wire format for a LightSettings describing lighting for a 3d scene. 3d lighting provides the following lights, all of which are optional:
- A "portrait" light affixed to the camera and pointing directly forward into the scene. Color: white.
- A second directional light. Color: white.
- This can be a solar shadow-casting light, or (when shadows are disabled) a roughly overhead light oriented in view space.
- A pair of hemisphere lights pointing in opposite directions along the world Z axis. Each has its own customizable color.
- An ambient light of any color applied equally to all surfaces. Specular intensity of all lights is controlled separately. Light intensities are typically expressed in [0..1] but can be as large as 5.
@see DisplayStyle3dSettingsProps
Properties
Name | Type | Description | |
---|---|---|---|
ambient | AmbientLightProps | undefined | Ambient light settings. | |
fresnel | FresnelSettingsProps | undefined | Fresnel settings. | |
hemisphere | HemisphereLightsProps | undefined | Hemisphere light settings. | |
numCels | number | undefined | Applies a cel-shaded effect. | |
portrait | { intensity?: number } | undefined | A white portrait light affixed to the camera and pointing directly forward into the scene. | |
solar | SolarLightProps | undefined | Solar light settings. | |
specularIntensity | number | undefined | Specular intensity applied to all lights. |
Defined in
- core/common/src/LightSettings.ts Line 394
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.