HemisphereLightsProps Interface
Wire format for a pair of hemisphere lights associated with a LightSettingsProps. Hemisphere lights are oriented in opposite directions along the world Z axis. Each has its own color; they share one intensity. They are often used to simulate outdoor reflection of light from the ground and sky, so the colors often match the ground and sky colors of the SkyBox.
Properties
Name | Type | Description | |
---|---|---|---|
intensity | number | undefined | Intensity of the lights. | |
lowerColor | RgbColorProps | undefined | The color of the upward-facing light. | |
upperColor | RgbColorProps | undefined | The color of the downward-facing light. |
Defined in
- core/common/src/LightSettings.ts Line 207
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.