HemisphereLights Class
Describes a pair of hemisphere lights associated with a LightSettings.
Methods
Name | Description | |
---|---|---|
constructor(json?: HemisphereLightsProps): HemisphereLights | ||
clone(changed?: HemisphereLightsProps): HemisphereLights | Create a copy of these lights, identical except for any properties explicitly specified by changed . |
|
equals(rhs: HemisphereLights): boolean | ||
toJSON(): undefined | HemisphereLightsProps |
Properties
Name | Type | Description | |
---|---|---|---|
intensity Readonly | number | ||
lowerColor Readonly | RgbColor | ||
upperColor Readonly | RgbColor |
Defined in
- core/common/src/LightSettings.ts Line 223
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.