TitleText Class

A graphical DetailingSymbol that contains title text.

Extends

Methods

Name Description
constructor(props: GeometricElement2dProps, iModel: IModelDb): TitleText    

Inherited methods

Name Inherited from Description
calculateRange3d(): Range3d Inherited DetailingSymbol  
collectPredecessorIds(predecessorIds: EntityReferenceSet): void Protected Inherited DetailingSymbol Collect the Ids of this element's references at this level of the class hierarchy.
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected Inherited DetailingSymbol Collect the Ids of this entity's references at this level of the class hierarchy.
delete(): void Inherited DetailingSymbol Delete this Element from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited DetailingSymbol Call a function for each property of this Entity.
DetailingSymbol Get the class metadata for this element.
getDisplayLabel(): string Inherited DetailingSymbol Get a display label for this Element.
getJsonProperty(nameSpace: string): any Inherited DetailingSymbol Get a JSON property of this element, by namespace
getPlacementTransform(): Transform Inherited DetailingSymbol Get the Transform from the Placement of this GeometricElement
getPredecessorIds(): Id64Set Inherited DetailingSymbol Get the Ids of this element's references.
getReferenceIds(): EntityReferenceSet Inherited DetailingSymbol Get the set of this entity's entity references, EntityReferenceSet.
getToolTipMessage(): string[] Inherited DetailingSymbol Get a list of HTML strings that describe this Element for the tooltip.
getUserProperties(namespace: string): any Inherited DetailingSymbol Get a set of JSON user properties by namespace
insert(): string Inherited DetailingSymbol Insert this Element into the iModel.
is2d(): this is GeometricElement2d Inherited DetailingSymbol Type guard for instanceof GeometricElement2d
is3d(): this is GeometricElement3d Inherited DetailingSymbol Type guard for instanceof GeometricElement3d
removeUserProperties(nameSpace: string): void Inherited DetailingSymbol Remove a set of JSON user properties, specified by namespace, from this Element
setJsonProperty(nameSpace: string, value: any): void Inherited DetailingSymbol  
setUserProperties(nameSpace: string, value: any): void Inherited DetailingSymbol Change a set of user JSON properties of this Element by namespace.
toJSON(): GeometricElement2dProps Inherited DetailingSymbol Obtain the JSON representation of this Entity.
update(): void Inherited DetailingSymbol Update this Element in the iModel.
is(otherClass: ): boolean Static Inherited DetailingSymbol return whether this Entity class is a subclass of another Entity class
onAllInputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited DetailingSymbol Called on an element in a graph after all of its inputs have been processed and before its outputs are processed.
onBeforeOutputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited DetailingSymbol Called when a root element in a subgraph is changed and before its outputs are processed.
onChildAdd(_arg: OnChildElementPropsArg): void Protected Static Inherited DetailingSymbol Called when an existing element is about to be updated so that an instance of this class will become its new parent.
onChildAdded(_arg: OnChildElementIdArg): void Protected Static Inherited DetailingSymbol Called after an existing element has been updated so that an instance of this class is its new parent.
onChildDelete(_arg: OnChildElementIdArg): void Protected Static Inherited DetailingSymbol Called when an element with an instance of this class as its parent is about to be deleted.
onChildDeleted(_arg: OnChildElementIdArg): void Protected Static Inherited DetailingSymbol Called after an element with an instance of this class as its parent was successfully deleted.
onChildDrop(_arg: OnChildElementIdArg): void Protected Static Inherited DetailingSymbol Called when an element with an instance of this class as its parent is about to be updated change to a different parent.
onChildDropped(_arg: OnChildElementIdArg): void Protected Static Inherited DetailingSymbol Called after an element with an instance of this class as its previous parent was updated to have a new parent.
onChildInsert(_arg: OnChildElementPropsArg): void Protected Static Inherited DetailingSymbol Called when a new element with an instance of this class as its parent is about to be inserted.
onChildInserted(_arg: OnChildElementIdArg): void Protected Static Inherited DetailingSymbol Called after a new element with an instance of this class as its parent was inserted.
onChildUpdate(_arg: OnChildElementPropsArg): void Protected Static Inherited DetailingSymbol Called when an element with an instance of this class as its parent is about to be updated.
onChildUpdated(_arg: OnChildElementIdArg): void Protected Static Inherited DetailingSymbol Called after an element with an instance of this the class as its parent was updated.
onCloned(_context: IModelElementCloneContext, _sourceProps: ElementProps, _targetProps: ElementProps): void Protected Static Inherited DetailingSymbol Called during the iModel transformation process after an Element from the source iModel was cloned for the target iModel.
onDelete(arg: OnElementIdArg): void Protected Static Inherited DetailingSymbol Called before an Element is deleted.
onDeleted(_arg: OnElementIdArg): void Protected Static Inherited DetailingSymbol Called after an Element was deleted.
onInsert(arg: OnElementPropsArg): void Protected Static Inherited DetailingSymbol Called before a new Element is inserted.
onInserted(arg: OnElementIdArg): void Protected Static Inherited DetailingSymbol Called after a new Element was inserted.
onSubModelDelete(_arg: OnSubModelIdArg): void Protected Static Inherited DetailingSymbol Called when a sub-model of an instance of this class is being deleted.
onSubModelDeleted(_arg: OnSubModelIdArg): void Protected Static Inherited DetailingSymbol Called after a sub-model of an instance of this class was deleted.
onSubModelInsert(_arg: OnSubModelPropsArg): void Protected Static Inherited DetailingSymbol Called when an instance of this class is being sub-modeled by a new Model.
onSubModelInserted(_arg: OnSubModelIdArg): void Protected Static Inherited DetailingSymbol Called after an instance of this class was sub-modeled by a new Model.
onUpdate(arg: OnElementPropsArg): void Protected Static Inherited DetailingSymbol Called before an Element is updated.
onUpdated(_arg: OnElementIdArg): void Protected Static Inherited DetailingSymbol Called after an Element was updated.

Properties

Name Type Description
className Accessor Static ReadOnly string The name of the BIS class associated with this class.  

Inherited properties

Name Type Inherited from Description
category Inherited string DetailingSymbol The Id of the Category for this GeometricElement.
classFullName Accessor Inherited ReadOnly string DetailingSymbol Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor Static Inherited ReadOnly string DetailingSymbol Get the full BIS class name of this Entity in the form "schema:class"
className Accessor Inherited ReadOnly string DetailingSymbol The name of the BIS class associated with this class.
code Inherited Code DetailingSymbol The Code for this element
elementGeometryBuilderParams Inherited ElementGeometryBuilderParams | undefined DetailingSymbol How to build the element's GeometryStream.
federationGuid Inherited string | undefined DetailingSymbol A FederationGuid assigned to this element by some other federated database
geom Inherited GeometryStreamProps | undefined DetailingSymbol The GeometryStream for this GeometricElement.
id Inherited string DetailingSymbol The Id of this Entity.
iModel Inherited IModelDb DetailingSymbol The IModelDb that contains this Entity
isInstanceOfEntity Readonly Inherited "true" DetailingSymbol An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
jsonProperties Readonly Inherited { T } DetailingSymbol Optional json properties of this element.
model Readonly Inherited string DetailingSymbol The ModelId of the Model containing this element
parent Inherited RelatedElement | undefined DetailingSymbol The parent element, if present, of this element.
placement Inherited Placement2d DetailingSymbol The origin, orientation, and bounding box of this GeometricElement.
requiredReferenceKeys Static Readonly Inherited ReadonlyArray DetailingSymbol  
schema Static Inherited DetailingSymbol The Schema that defines this class.
schemaName Accessor Inherited ReadOnly string DetailingSymbol The name of the BIS Schema that defines this class
typeDefinition Inherited TypeDefinition | undefined DetailingSymbol  
userLabel Inherited string | undefined DetailingSymbol A user-assigned label for this element.

Defined in

Last Updated: 14 November, 2024