GeometricElement2dProps Interface

Properties that define a GeometricElement2d

Extends

Properties

Name Type Description
placement Placement2dProps | undefined The placement properties  
typeDefinition RelatedElementProps | undefined    

Inherited properties

Name Type Inherited from Description
category Inherited string GeometricElementProps The id of the category for this geometric element.
classFullName Inherited string GeometricElementProps The full name of the ECClass for this entity, in the form "Schema:ClassName"
code Inherited CodeProps GeometricElementProps The Code for this element
elementGeometryBuilderParams Inherited ElementGeometryBuilderParams | undefined GeometricElementProps Describes how to build the element's GeometryStream, as an alternative to geom.
federationGuid Inherited string | undefined GeometricElementProps A FederationGuid assigned to this element.
geom Inherited GeometryStreamProps | undefined GeometricElementProps The geometry stream properties
id Inherited string | undefined GeometricElementProps The Id of the entity.
isInstanceOfEntity Readonly Inherited undefined | undefined GeometricElementProps A non-existent property used to discriminate between EntityProps and Entity.
jsonProperties Inherited any | undefined GeometricElementProps Optional json properties of this element.
model Inherited string GeometricElementProps The Id of the Model containing this element
parent Inherited RelatedElementProps | undefined GeometricElementProps The Parent of this element, if defined.
userLabel Inherited string | undefined GeometricElementProps A user-assigned label for this element.

Defined in

Last Updated: 14 November, 2024