GraphicalElement3d Class

A 3d Graphical Element

Extends

Extended by

Methods

Name Description
constructor(props: GeometricElement3dProps, iModel: IModelDb): GraphicalElement3d Protected    

Inherited methods

Name Inherited from Description
calculateRange3d(): Range3d Inherited GeometricElement3d  
collectPredecessorIds(predecessorIds: EntityReferenceSet): void Protected Inherited GeometricElement3d Collect the Ids of this element's references at this level of the class hierarchy.
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected Inherited GeometricElement3d Collect the Ids of this entity's references at this level of the class hierarchy.
delete(): void Inherited GeometricElement3d Delete this Element from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited GeometricElement3d Call a function for each property of this Entity.
GeometricElement3d Get the class metadata for this element.
getDisplayLabel(): string Inherited GeometricElement3d Get a display label for this Element.
getJsonProperty(nameSpace: string): any Inherited GeometricElement3d Get a JSON property of this element, by namespace
getPlacementTransform(): Transform Inherited GeometricElement3d Get the Transform from the Placement of this GeometricElement
getPredecessorIds(): Id64Set Inherited GeometricElement3d Get the Ids of this element's references.
getReferenceIds(): EntityReferenceSet Inherited GeometricElement3d Get the set of this entity's entity references, EntityReferenceSet.
getToolTipMessage(): string[] Inherited GeometricElement3d Get a list of HTML strings that describe this Element for the tooltip.
getUserProperties(namespace: string): any Inherited GeometricElement3d Get a set of JSON user properties by namespace
insert(): string Inherited GeometricElement3d Insert this Element into the iModel.
is2d(): this is GeometricElement2d Inherited GeometricElement3d Type guard for instanceof GeometricElement2d
is3d(): this is GeometricElement3d Inherited GeometricElement3d Type guard for instanceof GeometricElement3d
removeUserProperties(nameSpace: string): void Inherited GeometricElement3d Remove a set of JSON user properties, specified by namespace, from this Element
setJsonProperty(nameSpace: string, value: any): void Inherited GeometricElement3d  
setUserProperties(nameSpace: string, value: any): void Inherited GeometricElement3d Change a set of user JSON properties of this Element by namespace.
toJSON(): GeometricElement3dProps Inherited GeometricElement3d Obtain the JSON representation of this Entity.
update(): void Inherited GeometricElement3d Update this Element in the iModel.
is(otherClass: ): boolean Static Inherited GeometricElement3d return whether this Entity class is a subclass of another Entity class
onAllInputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited GeometricElement3d Called on an element in a graph after all of its inputs have been processed and before its outputs are processed.
onBeforeOutputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited GeometricElement3d Called when a root element in a subgraph is changed and before its outputs are processed.
onChildAdd(_arg: OnChildElementPropsArg): void Protected Static Inherited GeometricElement3d Called when an existing element is about to be updated so that an instance of this class will become its new parent.
onChildAdded(_arg: OnChildElementIdArg): void Protected Static Inherited GeometricElement3d Called after an existing element has been updated so that an instance of this class is its new parent.
onChildDelete(_arg: OnChildElementIdArg): void Protected Static Inherited GeometricElement3d Called when an element with an instance of this class as its parent is about to be deleted.
onChildDeleted(_arg: OnChildElementIdArg): void Protected Static Inherited GeometricElement3d Called after an element with an instance of this class as its parent was successfully deleted.
onChildDrop(_arg: OnChildElementIdArg): void Protected Static Inherited GeometricElement3d Called when an element with an instance of this class as its parent is about to be updated change to a different parent.
onChildDropped(_arg: OnChildElementIdArg): void Protected Static Inherited GeometricElement3d Called after an element with an instance of this class as its previous parent was updated to have a new parent.
onChildInsert(_arg: OnChildElementPropsArg): void Protected Static Inherited GeometricElement3d Called when a new element with an instance of this class as its parent is about to be inserted.
onChildInserted(_arg: OnChildElementIdArg): void Protected Static Inherited GeometricElement3d Called after a new element with an instance of this class as its parent was inserted.
onChildUpdate(_arg: OnChildElementPropsArg): void Protected Static Inherited GeometricElement3d Called when an element with an instance of this class as its parent is about to be updated.
onChildUpdated(_arg: OnChildElementIdArg): void Protected Static Inherited GeometricElement3d Called after an element with an instance of this the class as its parent was updated.
onCloned(_context: IModelElementCloneContext, _sourceProps: ElementProps, _targetProps: ElementProps): void Protected Static Inherited GeometricElement3d Called during the iModel transformation process after an Element from the source iModel was cloned for the target iModel.
onDelete(arg: OnElementIdArg): void Protected Static Inherited GeometricElement3d Called before an Element is deleted.
onDeleted(_arg: OnElementIdArg): void Protected Static Inherited GeometricElement3d Called after an Element was deleted.
onInsert(arg: OnElementPropsArg): void Protected Static Inherited GeometricElement3d Called before a new Element is inserted.
onInserted(arg: OnElementIdArg): void Protected Static Inherited GeometricElement3d Called after a new Element was inserted.
onSubModelDelete(_arg: OnSubModelIdArg): void Protected Static Inherited GeometricElement3d Called when a sub-model of an instance of this class is being deleted.
onSubModelDeleted(_arg: OnSubModelIdArg): void Protected Static Inherited GeometricElement3d Called after a sub-model of an instance of this class was deleted.
onSubModelInsert(_arg: OnSubModelPropsArg): void Protected Static Inherited GeometricElement3d Called when an instance of this class is being sub-modeled by a new Model.
onSubModelInserted(_arg: OnSubModelIdArg): void Protected Static Inherited GeometricElement3d Called after an instance of this class was sub-modeled by a new Model.
onUpdate(arg: OnElementPropsArg): void Protected Static Inherited GeometricElement3d Called before an Element is updated.
onUpdated(_arg: OnElementIdArg): void Protected Static Inherited GeometricElement3d Called after an Element was updated.

Properties

Name Type Description
className Accessor Static ReadOnly string The name of the BIS class associated with this class.  

Inherited properties

Name Type Inherited from Description
category Inherited string GeometricElement3d The Id of the Category for this GeometricElement.
classFullName Accessor Inherited ReadOnly string GeometricElement3d Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor Static Inherited ReadOnly string GeometricElement3d Get the full BIS class name of this Entity in the form "schema:class"
className Accessor Inherited ReadOnly string GeometricElement3d The name of the BIS class associated with this class.
code Inherited Code GeometricElement3d The Code for this element
elementGeometryBuilderParams Inherited ElementGeometryBuilderParams | undefined GeometricElement3d How to build the element's GeometryStream.
federationGuid Inherited string | undefined GeometricElement3d A FederationGuid assigned to this element by some other federated database
geom Inherited GeometryStreamProps | undefined GeometricElement3d The GeometryStream for this GeometricElement.
id Inherited string GeometricElement3d The Id of this Entity.
iModel Inherited IModelDb GeometricElement3d The IModelDb that contains this Entity
isInstanceOfEntity Readonly Inherited "true" GeometricElement3d An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
jsonProperties Readonly Inherited { T } GeometricElement3d Optional json properties of this element.
model Readonly Inherited string GeometricElement3d The ModelId of the Model containing this element
parent Inherited RelatedElement | undefined GeometricElement3d The parent element, if present, of this element.
placement Inherited Placement3d GeometricElement3d The origin, orientation, and bounding box of this GeometricElement.
requiredReferenceKeys Static Readonly Inherited ReadonlyArray GeometricElement3d  
schema Static Inherited GeometricElement3d The Schema that defines this class.
schemaName Accessor Inherited ReadOnly string GeometricElement3d The name of the BIS Schema that defines this class
typeDefinition Inherited TypeDefinition | undefined GeometricElement3d  
userLabel Inherited string | undefined GeometricElement3d A user-assigned label for this element.

Defined in

Last Updated: 14 November, 2024