SelectedNodeInstancesSpecification Interface
Returns content for selected (input) instances.
@see Selected node instances specification reference documentation page
Extends
Properties
Name | Type | Description | |
---|---|---|---|
acceptableClassNames | string[] | undefined | Specifies a list of class names which the input instances have to match for the specification to be used. | |
acceptablePolymorphically | boolean | undefined | Specifies whether derived classes of acceptableClassNames should be included in the content. | |
acceptableSchemaName | string | undefined | Specifies ECSchema name which the input instances have to match for the specification to be used. | |
specType | "SelectedNodeInstances" | Used for serializing to JSON. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
calculatedProperties Inherited | CalculatedPropertiesSpecification[] | undefined | ContentSpecificationBase | Specifications of calculated properties whose values are |
onlyIfNotHandled Inherited | boolean | undefined | ContentSpecificationBase | Specifies whether this specification should be ignored if another specification was handled before as |
priority Inherited | number | undefined | ContentSpecificationBase | Controls the order in which specifications are handled — specification with higher priority value is handled |
propertyCategories Inherited | PropertyCategorySpecification[] | undefined | ContentSpecificationBase | Specifications for custom categories. |
propertyOverrides Inherited | PropertySpecification[] | undefined | ContentSpecificationBase | Specifications for various property overrides that allow customizing property display. |
relatedInstances Inherited | RelatedInstanceSpecification[] | undefined | ContentSpecificationBase | Specifications of related instances that can be used when creating the content. |
relatedProperties Inherited | RelatedPropertiesSpecification[] | undefined | ContentSpecificationBase | Specifications of related properties which are |
showImages Inherited | boolean | undefined | ContentSpecificationBase | Should image IDs be calculated for the returned instances. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.