PropertySpecification Interface
This specification allows overriding some attributes of specific ECProperty or define how it's displayed.
@see Property specification reference documentation page
Extends
Properties
Name | Type | Description | |
---|---|---|---|
name | string | Name of the ECProperty to apply overrides to. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
categoryId Inherited | string | CategoryIdentifier | PropertyOverrides | The attribute allows moving the property into a different category. |
doNotHideOtherPropertiesOnDisplayOverride Inherited | boolean | undefined | PropertyOverrides | This attribute controls whether making the property visible using isDisplayed attribute should automatically hide |
editor Inherited | PropertyEditorSpecification | undefined | PropertyOverrides | Custom property editor specification that allows assigning |
isDisplayed Inherited | string | boolean | PropertyOverrides | This attribute controls whether the particular property is present in the result, even when it is marked as hidden in the |
isReadOnly Inherited | boolean | undefined | PropertyOverrides | This attribute controls whether the property field is read-only. |
labelOverride Inherited | string | undefined | PropertyOverrides | This is an attribute that allows overriding the property label. |
overridesPriority Inherited | number | undefined | PropertyOverrides | There may be multiple property specifications that apply to a single property and there may be conflicts between |
priority Inherited | number | undefined | PropertyOverrides | This attribute controls the order in which property fields should be displayed. |
renderer Inherited | CustomRendererSpecification | undefined | PropertyOverrides | Custom property renderer specification that allows assigning a |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.