PropertyOverrides Interface
A container structure for possible property overrides
@see Property specification reference documentation page
Properties
Name | Type | Description | |
---|---|---|---|
categoryId | string | CategoryIdentifier | The attribute allows moving the property into a different category. | |
doNotHideOtherPropertiesOnDisplayOverride | boolean | undefined | This attribute controls whether making the property visible using isDisplayed attribute should automatically hide | |
editor | PropertyEditorSpecification | undefined | Custom property editor specification that allows assigning | |
isDisplayed | string | boolean | This attribute controls whether the particular property is present in the result, even when it is marked as hidden in the | |
isReadOnly | boolean | undefined | This attribute controls whether the property field is read-only. | |
labelOverride | string | undefined | This is an attribute that allows overriding the property label. | |
overridesPriority | number | undefined | There may be multiple property specifications that apply to a single property and there may be conflicts between | |
priority | number | undefined | This attribute controls the order in which property fields should be displayed. | |
renderer | CustomRendererSpecification | undefined | Custom property renderer specification that allows assigning a |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.