CalculatedPropertiesSpecification Interface
This content modifier allows including additional calculated properties into the content.
@see Calculated properties specification reference documentation page
Properties
Name | Type | Description | |
---|---|---|---|
categoryId | string | CategoryIdentifier | The attribute allows moving the calculated property into a different category. | |
editor | PropertyEditorSpecification | undefined | Custom property editor specification that allows assigning | |
extendedData | { T } | undefined | A map of ECExpressions whose | |
label | string | Specifies label of the calculated property. | |
priority | number | undefined | Assign a custom priority to the property. | |
renderer | CustomRendererSpecification | undefined | Custom property renderer specification that allows assigning a | |
type | "string" | "boolean" | "bool" | "dateTime" | "double" | "int" | "long" | Specifies return type of the calculated property. | |
value | string | undefined | Defines an expression to calculate the value. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.