ContentSpecificationBase Interface
Base interface for all ContentSpecification implementations. Not
meant to be used directly, see ContentSpecification
.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
onlyIfNotHandled | boolean | undefined | Specifies whether this specification should be ignored if another specification was handled before as | |
priority | number | undefined | Controls the order in which specifications are handled — specification with higher priority value is handled | |
relatedInstances | RelatedInstanceSpecification[] | undefined | Specifications of related instances that can be used when creating the content. | |
showImages | boolean | undefined | Should image IDs be calculated for the returned instances. | Deprecated |
specType | "ContentInstancesOfSpecificClasses" | "ContentRelatedInstances" | "SelectedNodeInstances" | Used for serializing to JSON. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
calculatedProperties Inherited | CalculatedPropertiesSpecification[] | undefined | ContentModifiersList | Specifications of calculated properties whose values are |
propertyCategories Inherited | PropertyCategorySpecification[] | undefined | ContentModifiersList | Specifications for custom categories. |
propertyOverrides Inherited | PropertySpecification[] | undefined | ContentModifiersList | Specifications for various property overrides that allow customizing property display. |
relatedProperties Inherited | RelatedPropertiesSpecification[] | undefined | ContentModifiersList | Specifications of related properties which are |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.