RelatedPropertiesSpecification Interface
This specification allows including related instance properties into the content.
@see Related properties specification specification reference documentation page
Properties
Name | Type | Description | |
---|---|---|---|
autoExpand | boolean | undefined | Should the field containing related properties be assigned the autoExpand | |
forceCreateRelationshipCategory | boolean | undefined | Specifies whether a relationship category should be created regardless of whether any relationship properties were included. | |
handleTargetClassPolymorphically | boolean | undefined | The attribute tells whether the target class specified through propertiesSource should be handled | |
instanceFilter | string | undefined | Condition for filtering instances targeted by the propertiesSource attribute. | |
nestedRelatedProperties | RelatedPropertiesSpecification[] | undefined | The attribute allows loading additional related properties that are related to the target instance of this specification. | |
properties | "*" | "none" | string | PropertySpecification[] | List of names or definitions of related class properties that should be included in the content. | |
propertiesSource | RelationshipPathSpecification | Specifies a chain of relationship path specifications that | |
relationshipMeaning | "SameInstance" | "RelatedInstance" | The attribute describes what the related properties mean to the primary instance | |
relationshipProperties | "*" | "none" | string | PropertySpecification[] | List of names or definitions of relationship class properties that should be included in the content. | |
skipIfDuplicate | boolean | undefined | Specifies whether the specification should be ignored if another higher priority specification for the same relationship already exists. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.