ContentInstancesOfSpecificClassesSpecification Interface
This specification creates content for all instances of specific ECClasses.
@see Content instances of specific classes specification reference documentation page
Extends
Properties
Name | Type | Description | |
---|---|---|---|
classes | MultiSchemaClassesSpecification | MultiSchemaClassesSpecification[] | Defines a set of multi schema classes that specify which | |
excludedClasses | MultiSchemaClassesSpecification | MultiSchemaClassesSpecification[] | Defines a set of multi schema classes that prevents specified | |
handlePropertiesPolymorphically | boolean | undefined | Specifies whether properties of derived classes should be included in the content. | |
instanceFilter | string | undefined | Specifies an ECExpression for filtering instances | |
specType | "ContentInstancesOfSpecificClasses" | Used for serializing to JSON. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
calculatedProperties Inherited | CalculatedPropertiesSpecification[] | undefined | ContentSpecificationBase | Specifications of calculated properties whose values are |
onlyIfNotHandled Inherited | boolean | undefined | ContentSpecificationBase | Specifies whether this specification should be ignored if another specification was handled before as |
priority Inherited | number | undefined | ContentSpecificationBase | Controls the order in which specifications are handled — specification with higher priority value is handled |
propertyCategories Inherited | PropertyCategorySpecification[] | undefined | ContentSpecificationBase | Specifications for custom categories. |
propertyOverrides Inherited | PropertySpecification[] | undefined | ContentSpecificationBase | Specifications for various property overrides that allow customizing property display. |
relatedInstances Inherited | RelatedInstanceSpecification[] | undefined | ContentSpecificationBase | Specifications of related instances that can be used when creating the content. |
relatedProperties Inherited | RelatedPropertiesSpecification[] | undefined | ContentSpecificationBase | Specifications of related properties which are |
showImages Inherited | boolean | undefined | ContentSpecificationBase | Should image IDs be calculated for the returned instances. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.