PrimitiveOrEnumPropertyBase Class

Extends

Extended by

Methods

Name Description
constructor(ecClass: ECClass, name: string, type: PropertyType): PrimitiveOrEnumPropertyBase    
fromJSON(propertyBaseProps: PrimitiveOrEnumPropertyBaseProps): Promise<void>    
fromJSONSync(propertyBaseProps: PrimitiveOrEnumPropertyBaseProps): void    
toJSON(): PrimitiveOrEnumPropertyBaseProps Save this PrimitiveOrEnumPropertyBase's properties to an object for serializing to JSON.  

Inherited methods

Name Inherited from Description
addCustomAttribute(customAttribute: CustomAttribute): void Protected Inherited Property  
getCategorySync(): undefined | PropertyCategory Inherited Property  
getCustomAttributes(): Promise<> Inherited Property Retrieve all custom attributes in the current property and its base
getCustomAttributesSync(): Inherited Property Retrieve all custom attributes in the current property and its base.
getKindOfQuantitySync(): undefined | KindOfQuantity Inherited Property  
isArray(): this is AnyArrayProperty Inherited Property  
isEnumeration(): this is AnyEnumerationProperty Inherited Property  
isNavigation(): this is NavigationProperty Inherited Property  
isPrimitive(): this is AnyPrimitiveProperty Inherited Property  
isStruct(): this is AnyStructProperty Inherited Property  
setName(name: ECName): void Protected Inherited Property  

Properties

Name Type Description
_extendedTypeName Protected string | undefined    
_maxLength Protected number | undefined    
_maxValue Protected number | undefined    
_minLength Protected number | undefined    
_minValue Protected number | undefined    
extendedTypeName Accessor ReadOnly undefined | string    
maxLength Accessor ReadOnly undefined | number    
maxValue Accessor ReadOnly undefined | number    
minLength Accessor ReadOnly undefined | number    
minValue Accessor ReadOnly undefined | number    

Inherited properties

Name Type Inherited from Description
_category Protected Inherited LazyLoadedPropertyCategory | undefined Property  
_class Protected Inherited AnyClass Property  
_description Protected Inherited string | undefined Property  
_isReadOnly Protected Inherited boolean | undefined Property  
_kindOfQuantity Protected Inherited LazyLoadedKindOfQuantity | undefined Property  
_label Protected Inherited string | undefined Property  
_name Protected Inherited ECName Property  
_priority Protected Inherited number | undefined Property  
_type Protected Inherited PropertyType Property  
category Accessor Inherited ReadOnly undefined | LazyLoadedPropertyCategory Property  
class Accessor Inherited ReadOnly AnyClass Property  
customAttributes Accessor Inherited ReadOnly undefined | Property  
description Accessor Inherited ReadOnly undefined | string Property  
fullName Accessor Inherited ReadOnly string Property Returns the name in the format 'ClassName.PropertyName'.
isReadOnly Accessor Inherited ReadOnly boolean Property  
kindOfQuantity Accessor Inherited ReadOnly undefined | LazyLoadedKindOfQuantity Property  
label Accessor Inherited ReadOnly undefined | string Property  
name Accessor Inherited ReadOnly string Property  
priority Accessor Inherited ReadOnly number Property  
propertyType Accessor Inherited ReadOnly PropertyType Property  
schema Accessor Inherited ReadOnly Schema Property Returns the schema of the class holding the property.

Defined in

Last Updated: 14 November, 2024