NavigationProperty Class
Extends
Methods
Name | Description | |
---|---|---|
constructor(ecClass: ECClass, name: string, relationship: LazyLoadedRelationshipClass, direction?: StrengthDirection): NavigationProperty | ||
getRelationshipClassSync(): undefined | RelationshipClass | ||
toJSON(): NavigationPropertyProps | Save this NavigationProperty's properties to an object for serializing to JSON. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
addCustomAttribute(customAttribute: CustomAttribute): void Protected Inherited | Property | |
fromJSON(propertyProps: PropertyProps): Promise<void> Inherited | Property | |
fromJSONSync(propertyProps: PropertyProps): void Inherited | Property | |
getCategorySync(): undefined | PropertyCategory Inherited | Property | |
getCustomAttributes(): Promise<> Inherited | Property | Retrieve all custom attributes in the current property and its base |
getCustomAttributesSync(): Inherited | Property | Retrieve all custom attributes in the current property and its base. |
getKindOfQuantitySync(): undefined | KindOfQuantity Inherited | Property | |
isArray(): this is AnyArrayProperty Inherited | Property | |
isEnumeration(): this is AnyEnumerationProperty Inherited | Property | |
isNavigation(): this is NavigationProperty Inherited | Property | |
isPrimitive(): this is AnyPrimitiveProperty Inherited | Property | |
isStruct(): this is AnyStructProperty Inherited | Property | |
setName(name: ECName): void Protected Inherited | Property |
Properties
Name | Type | Description | |
---|---|---|---|
_direction Protected | StrengthDirection | ||
_relationshipClass Protected | LazyLoadedRelationshipClass | ||
direction Accessor ReadOnly | StrengthDirection | ||
relationshipClass Accessor ReadOnly | LazyLoadedRelationshipClass |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_category Protected Inherited | LazyLoadedPropertyCategory | undefined | Property | |
_class Protected Inherited | AnyClass | Property | |
_description Protected Inherited | string | undefined | Property | |
_isReadOnly Protected Inherited | boolean | undefined | Property | |
_kindOfQuantity Protected Inherited | LazyLoadedKindOfQuantity | undefined | Property | |
_label Protected Inherited | string | undefined | Property | |
_name Protected Inherited | ECName | Property | |
_priority Protected Inherited | number | undefined | Property | |
_type Protected Inherited | PropertyType | Property | |
category Accessor Inherited ReadOnly | undefined | LazyLoadedPropertyCategory | Property | |
class Accessor Inherited ReadOnly | AnyClass | Property | |
customAttributes Accessor Inherited ReadOnly | undefined | | Property | |
description Accessor Inherited ReadOnly | undefined | string | Property | |
fullName Accessor Inherited ReadOnly | string | Property | Returns the name in the format 'ClassName.PropertyName'. |
isReadOnly Accessor Inherited ReadOnly | boolean | Property | |
kindOfQuantity Accessor Inherited ReadOnly | undefined | LazyLoadedKindOfQuantity | Property | |
label Accessor Inherited ReadOnly | undefined | string | Property | |
name Accessor Inherited ReadOnly | string | Property | |
priority Accessor Inherited ReadOnly | number | Property | |
propertyType Accessor Inherited ReadOnly | PropertyType | Property | |
schema Accessor Inherited ReadOnly | Schema | Property | Returns the schema of the class holding the property. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.