PropertyCategory Class
Extends
Methods
Name | Description | |
---|---|---|
constructor(schema: Schema, name: string): PropertyCategory | ||
fromJSON(propertyCategoryProps: PropertyCategoryProps): Promise<void> | ||
fromJSONSync(propertyCategoryProps: PropertyCategoryProps): void | ||
toJSON(standalone: booleanfalse, includeSchemaVersion: booleanfalse): PropertyCategoryProps | Save this PropertyCategory's properties to an object for serializing to JSON. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
equalByKey(thisSchemaItem: SchemaItem, thatSchemaItemOrKey?: SchemaItemKey | SchemaItem): boolean Static Inherited | SchemaItem | Indicates if the two SchemaItem objects are equal by comparing their respective key properties. |
parseFullName(fullName: string): [string, string] Static Inherited | SchemaItem | Parses the given full name, {schemaName}.{schemaItemName} or {schemaName}:{schemaItemName}, into two separate strings. |
Properties
Name | Type | Description | |
---|---|---|---|
_priority Protected | number | ||
priority Accessor ReadOnly | number | ||
schemaItemType Readonly | PropertyCategory |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_description Protected Inherited | string | undefined | SchemaItem | |
_key Protected Inherited | SchemaItemKey | SchemaItem | |
_label Protected Inherited | string | undefined | SchemaItem | |
description Accessor Inherited ReadOnly | undefined | string | SchemaItem | |
fullName Accessor Inherited ReadOnly | string | SchemaItem | |
key Accessor Inherited ReadOnly | SchemaItemKey | SchemaItem | |
label Accessor Inherited ReadOnly | undefined | string | SchemaItem | |
name Accessor Inherited ReadOnly | string | SchemaItem | |
schema Readonly Inherited | Schema | SchemaItem |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.