Property Class
A common abstract class for all ECProperty types.
Extended by
Implements
Methods
Name | Description | |
---|---|---|
constructor(ecClass: ECClass, name: string, type: PropertyType): Property | ||
addCustomAttribute(customAttribute: CustomAttribute): void Protected | ||
fromJSON(propertyProps: PropertyProps): Promise<void> | ||
fromJSONSync(propertyProps: PropertyProps): void | ||
getCategorySync(): undefined | PropertyCategory | ||
getCustomAttributes(): Promise<> | Retrieve all custom attributes in the current property and its base | |
getCustomAttributesSync(): | Retrieve all custom attributes in the current property and its base. | |
getKindOfQuantitySync(): undefined | KindOfQuantity | ||
isArray(): this is AnyArrayProperty | ||
isEnumeration(): this is AnyEnumerationProperty | ||
isNavigation(): this is NavigationProperty | ||
isPrimitive(): this is AnyPrimitiveProperty | ||
isStruct(): this is AnyStructProperty | ||
setName(name: ECName): void Protected | ||
toJSON(): PropertyProps | Save this Property's properties to an object for serializing to JSON. |
Properties
Name | Type | Description | |
---|---|---|---|
_category Protected | LazyLoadedPropertyCategory | undefined | ||
_class Protected | AnyClass | ||
_description Protected | string | undefined | ||
_isReadOnly Protected | boolean | undefined | ||
_kindOfQuantity Protected | LazyLoadedKindOfQuantity | undefined | ||
_label Protected | string | undefined | ||
_name Protected | ECName | ||
_priority Protected | number | undefined | ||
_type Protected | PropertyType | ||
category Accessor ReadOnly | undefined | LazyLoadedPropertyCategory | ||
class Accessor ReadOnly | AnyClass | ||
customAttributes Accessor ReadOnly | undefined | | ||
description Accessor ReadOnly | undefined | string | ||
fullName Accessor ReadOnly | string | Returns the name in the format 'ClassName.PropertyName'. | |
isReadOnly Accessor ReadOnly | boolean | ||
kindOfQuantity Accessor ReadOnly | undefined | LazyLoadedKindOfQuantity | ||
label Accessor ReadOnly | undefined | string | ||
name Accessor ReadOnly | string | ||
priority Accessor ReadOnly | number | ||
propertyType Accessor ReadOnly | PropertyType | ||
schema Accessor ReadOnly | Schema | Returns the schema of the class holding the property. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.