PrimitiveProperty Class

Extends

Methods

Name Description
constructor(ecClass: ECClass, name: string, primitiveType: PrimitiveTypePrimitiveType.Integer): PrimitiveProperty    
fromJSON(primitivePropertyProps: PrimitivePropertyProps): Promise<void>    
fromJSONSync(primitivePropertyProps: PrimitivePropertyProps): void    
toJSON(): PrimitivePropertyProps Save this PrimitiveProperty's properties to an object for serializing to JSON.  

Inherited methods

Name Inherited from Description
addCustomAttribute(customAttribute: CustomAttribute): void Protected Inherited PrimitiveOrEnumPropertyBase  
getCategorySync(): undefined | PropertyCategory Inherited PrimitiveOrEnumPropertyBase  
getCustomAttributes(): Promise<> Inherited PrimitiveOrEnumPropertyBase Retrieve all custom attributes in the current property and its base
getCustomAttributesSync(): Inherited PrimitiveOrEnumPropertyBase Retrieve all custom attributes in the current property and its base.
getKindOfQuantitySync(): undefined | KindOfQuantity Inherited PrimitiveOrEnumPropertyBase  
isArray(): this is AnyArrayProperty Inherited PrimitiveOrEnumPropertyBase  
isEnumeration(): this is AnyEnumerationProperty Inherited PrimitiveOrEnumPropertyBase  
isNavigation(): this is NavigationProperty Inherited PrimitiveOrEnumPropertyBase  
isPrimitive(): this is AnyPrimitiveProperty Inherited PrimitiveOrEnumPropertyBase  
isStruct(): this is AnyStructProperty Inherited PrimitiveOrEnumPropertyBase  
setName(name: ECName): void Protected Inherited PrimitiveOrEnumPropertyBase  

Properties

Name Type Description
primitiveType Accessor ReadOnly PrimitiveType    

Inherited properties

Name Type Inherited from Description
_category Protected Inherited LazyLoadedPropertyCategory | undefined PrimitiveOrEnumPropertyBase  
_class Protected Inherited AnyClass PrimitiveOrEnumPropertyBase  
_description Protected Inherited string | undefined PrimitiveOrEnumPropertyBase  
_extendedTypeName Protected Inherited string | undefined PrimitiveOrEnumPropertyBase  
_isReadOnly Protected Inherited boolean | undefined PrimitiveOrEnumPropertyBase  
_kindOfQuantity Protected Inherited LazyLoadedKindOfQuantity | undefined PrimitiveOrEnumPropertyBase  
_label Protected Inherited string | undefined PrimitiveOrEnumPropertyBase  
_maxLength Protected Inherited number | undefined PrimitiveOrEnumPropertyBase  
_maxValue Protected Inherited number | undefined PrimitiveOrEnumPropertyBase  
_minLength Protected Inherited number | undefined PrimitiveOrEnumPropertyBase  
_minValue Protected Inherited number | undefined PrimitiveOrEnumPropertyBase  
_name Protected Inherited ECName PrimitiveOrEnumPropertyBase  
_priority Protected Inherited number | undefined PrimitiveOrEnumPropertyBase  
_type Protected Inherited PropertyType PrimitiveOrEnumPropertyBase  
category Accessor Inherited ReadOnly undefined | LazyLoadedPropertyCategory PrimitiveOrEnumPropertyBase  
class Accessor Inherited ReadOnly AnyClass PrimitiveOrEnumPropertyBase  
customAttributes Accessor Inherited ReadOnly undefined | PrimitiveOrEnumPropertyBase  
description Accessor Inherited ReadOnly undefined | string PrimitiveOrEnumPropertyBase  
extendedTypeName Accessor Inherited ReadOnly undefined | string PrimitiveOrEnumPropertyBase  
fullName Accessor Inherited ReadOnly string PrimitiveOrEnumPropertyBase Returns the name in the format 'ClassName.PropertyName'.
isReadOnly Accessor Inherited ReadOnly boolean PrimitiveOrEnumPropertyBase  
kindOfQuantity Accessor Inherited ReadOnly undefined | LazyLoadedKindOfQuantity PrimitiveOrEnumPropertyBase  
label Accessor Inherited ReadOnly undefined | string PrimitiveOrEnumPropertyBase  
maxLength Accessor Inherited ReadOnly undefined | number PrimitiveOrEnumPropertyBase  
maxValue Accessor Inherited ReadOnly undefined | number PrimitiveOrEnumPropertyBase  
minLength Accessor Inherited ReadOnly undefined | number PrimitiveOrEnumPropertyBase  
minValue Accessor Inherited ReadOnly undefined | number PrimitiveOrEnumPropertyBase  
name Accessor Inherited ReadOnly string PrimitiveOrEnumPropertyBase  
priority Accessor Inherited ReadOnly number PrimitiveOrEnumPropertyBase  
propertyType Accessor Inherited ReadOnly PropertyType PrimitiveOrEnumPropertyBase  
schema Accessor Inherited ReadOnly Schema PrimitiveOrEnumPropertyBase Returns the schema of the class holding the property.

Defined in

Last Updated: 14 November, 2024