StringSchemaKey Class
A SchemaKey implementation that aids in identifying Schema strings via the addition of the schemaText property. The schemaText is the full XML string representation of the Schema.
Extends
Methods
Name | Description | |
---|---|---|
constructor(key: SchemaKey, schemaText: string): StringSchemaKey | Initializes a new StringSchemaKey object. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
compareByName(rhs: string | SchemaKey): boolean Inherited | SchemaKey | Compares two schema names, case-insensitive. |
compareByVersion(rhs: SchemaKey): number Inherited | SchemaKey | Compares two schema versions. |
matches(rhs: Readonly<SchemaKey>, matchType?: SchemaMatchType): boolean Inherited | SchemaKey | |
toJSON(): SchemaKeyProps Inherited | SchemaKey | Save this SchemaKey's properties to an object for serializing to JSON. |
toString(padZeroes?: boolean): string Inherited | SchemaKey | Creates a string, in the format 'RR.ww.mm', representing this SchemaKey. |
fromJSON(props: SchemaKeyProps): SchemaKey Static Inherited | SchemaKey | Deserializes a SchemaKeyProps JSON object into a SchemaKey object. |
parseString(fullName: string): SchemaKey Static Inherited | SchemaKey |
Properties
Name | Type | Description | |
---|---|---|---|
schemaText | string |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_version Protected Inherited | ECVersion | SchemaKey | |
minorVersion Accessor Inherited ReadOnly | number | SchemaKey | |
name Accessor Inherited ReadOnly | string | SchemaKey | |
readVersion Accessor Inherited ReadOnly | number | SchemaKey | |
version Accessor Inherited ReadOnly | ECVersion | SchemaKey | |
writeVersion Accessor Inherited ReadOnly | number | SchemaKey |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.