ECVersion Class
Methods
Name | Description | |
---|---|---|
constructor(read?: number, write?: number, minor?: number): ECVersion | The constructor will throw an ECObjectsError if any of the parameters below are above the threshold. | |
compare(rhv: ECVersion): number | Compares two schema versions. | |
toString(padZeroes: booleantrue): string | Creates a string, in the format 'RR.ww.mm', representing this ECVersion. | |
fromString(versionString: string): ECVersion Static | Given a valid version string the |
Properties
Name | Type | Description | |
---|---|---|---|
minor Accessor ReadOnly | number | ||
read Accessor ReadOnly | number | ||
write Accessor ReadOnly | number |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.