PolygonTool Class

Tool for placing Markup Polygons

Extends

Methods

Name Description
constructor(_numSides?: number): PolygonTool    
createMarkup(svgMarkup: @svgdotjs/svg.js.G, ev: BeButtonEvent, isDynamics: boolean): void Protected    
getPoints(points: number[], center: Point3d, edge: Point3d, numSides: number, inscribe: boolean): boolean Protected    
showPrompt(): void Protected    

Inherited methods

Name Inherited from Description
applyToolSettingPropertyChange(_updatedValue: DialogPropertySyncItem): Promise<boolean> Inherited RedlineTool Used to receive property changes from UI.
autoLockTarget(): void Inherited RedlineTool Called on data button down event to lock the tool to its current target model.
beginDynamics(): void Inherited RedlineTool Call to initialize dynamics mode.
bumpToolSetting(_settingIndex?: number): Promise<boolean> Inherited RedlineTool Used to "bump" the value of a tool setting.
changeLocateState(enableLocate: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void Inherited RedlineTool Helper method to keep the view cursor, display of locate circle, and coordinate lock overrides consistent with AccuSnap.isLocateEnabled and AccuSnap.isSnapEnabled.
changeToolSettingPropertyValue(syncItem: DialogPropertySyncItem): boolean Inherited RedlineTool Helper method for responding to a tool setting property value change by updating saved settings.
clearDynamicsMarkup(_isDynamics: boolean): void Protected Inherited RedlineTool  
decorate(_context: DecorateContext): void Inherited RedlineTool Called to allow an active tool to display non-element decorations in overlay mode.
decorateSuspended(_context: DecorateContext): void Inherited RedlineTool Called to allow a suspended tool to display non-element decorations in overlay mode.
endDynamics(): void Inherited RedlineTool Call to terminate dynamics mode.
exitTool(): Promise<void> Inherited RedlineTool  
filterHit(_hit: HitDetail, _out?: LocateResponse): Promise<LocateFilterStatus> Inherited RedlineTool Invoked to allow tools to filter which elements can be located.
getCurrentButtonEvent(ev: BeButtonEvent): void Inherited RedlineTool Fill the supplied button event from the current cursor location.
getDecorationGeometry(_hit: HitDetail): undefined | GeometryStreamProps Inherited RedlineTool Called to allow snapping to pickable decoration geometry.
getPrompt(): string Inherited RedlineTool Returns the prompt based on the tool's current state.
getToolSettingPropertyLocked(_property: DialogProperty<any>): undefined | DialogProperty<any> Inherited RedlineTool Override to return the property that is disabled/enabled if the supplied property is a lock property.
getToolTip(_hit: HitDetail): Promise<string | HTMLElement> Inherited RedlineTool Invoked before the locate tooltip is displayed to retrieve the information about the located element.
initializeToolSettingPropertyValues(properties: DialogProperty<any>[]): void Inherited RedlineTool Helper method to establish initial values for tool setting properties from saved settings.
initLocateElements(enableLocate?: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void Inherited RedlineTool Helper method for tools that need to locate existing elements.
isCompatibleViewport(vp: Viewport, isSelectedViewChange: boolean): boolean Inherited RedlineTool Determine whether the supplied Viewport is compatible with this tool.
isComplete(_ev: BeButtonEvent): boolean Protected Inherited RedlineTool  
isValidLocation(ev: BeButtonEvent, isButtonEvent: boolean): boolean Inherited RedlineTool Checks that the adjusted point from the supplied button event is within the project extents for spatial views.
onAdded(el: @svgdotjs/svg.js.Element): void Protected Inherited RedlineTool  
onCleanup(): Promise<void> Inherited RedlineTool Invoked when the tool becomes no longer active, to perform additional cleanup logic
onDataButtonDown(ev: BeButtonEvent): Promise<EventHandled> Inherited RedlineTool Invoked when the data button is pressed.
onDataButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Inherited RedlineTool Invoked when the data button is released.
onDynamicFrame(_ev: BeButtonEvent, _context: DynamicsContext): void Inherited RedlineTool Called to allow Tool to display dynamic elements.
onInstall(): Promise<boolean> Inherited RedlineTool Override to execute additional logic when tool is installed.
onKeyTransition(_wentDown: boolean, _keyEvent: KeyboardEvent): Promise<EventHandled> Inherited RedlineTool Called when any key is pressed or released.
onMiddleButtonDown(_ev: BeButtonEvent): Promise<EventHandled> Inherited RedlineTool Invoked when the middle mouse button is pressed.
onMiddleButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Inherited RedlineTool Invoked when the middle mouse button is released.
onModifierKeyTransition(_wentDown: boolean, _modifier: BeModifierKeys, _event: KeyboardEvent): Promise<EventHandled> Inherited RedlineTool Called when Control, Shift, or Alt modifier keys are pressed or released.
onMouseEndDrag(ev: BeButtonEvent): Promise<EventHandled> Inherited RedlineTool Invoked when the button is released after onMouseStartDrag.
onMouseMotion(ev: BeButtonEvent): Promise<void> Inherited RedlineTool Invoked when the cursor is moving
onMouseStartDrag(_ev: BeButtonEvent): Promise<EventHandled> Inherited RedlineTool Invoked when the cursor begins moving while a button is depressed.
onMouseWheel(_ev: BeWheelEvent): Promise<EventHandled> Inherited RedlineTool Invoked when the mouse wheel moves.
onPostInstall(): Promise<void> Inherited RedlineTool Override to execute additional logic after tool becomes active
onRedoPreviousStep(): Promise<boolean> Inherited RedlineTool Called to reinstate to a previous tool state (ex.
onReinitialize(): Promise<void> Inherited RedlineTool Called to reset tool to initial state.
onResetButtonDown(_ev: BeButtonEvent): Promise<EventHandled> Inherited RedlineTool Invoked when the reset button is pressed.
onResetButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Inherited RedlineTool Invoked when the reset button is released.
onRestartTool(): Promise<void> Inherited RedlineTool Called when an external event may invalidate the current tool's state.
onSelectedViewportChanged(_previous: Viewport, current: Viewport): Promise<void> Inherited RedlineTool Called when active view changes.
onSuspend(): Promise<void> Inherited RedlineTool Notification of a ViewTool or InputCollector starting and this tool is being suspended.
onTouchCancel(ev: BeTouchEvent): Promise<void> Inherited RedlineTool Called when a touch point is interrupted in some way and needs to be dropped from the list of target touches.
onTouchComplete(ev: BeTouchEvent): Promise<void> Inherited RedlineTool Called when the last touch point is removed from the surface completing the current gesture.
onTouchEnd(_ev: BeTouchEvent): Promise<void> Inherited RedlineTool Called when user removes a touch point by lifting a finger or stylus from the surface.
onTouchMove(ev: BeTouchEvent): Promise<void> Inherited RedlineTool Called when a touch point moves along the surface.
onTouchMoveStart(ev: BeTouchEvent, startEv: BeTouchEvent): Promise<EventHandled> Inherited RedlineTool Called after at least one touch point has moved for an appreciable time and distance along the surface to not be considered a tap.
onTouchStart(_ev: BeTouchEvent): Promise<void> Inherited RedlineTool Called when user adds a touch point by placing a finger or stylus on the surface.
onTouchTap(_ev: BeTouchEvent): Promise<EventHandled> Inherited RedlineTool Called when touch point(s) are added and removed from a surface within a small time window without any touch point moving.
onUndoPreviousStep(): Promise<boolean> Inherited RedlineTool Called to reverse to a previous tool state (ex.
onUnsuspend(): Promise<void> Inherited RedlineTool Notification of a ViewTool or InputCollector exiting and this tool is being unsuspended.
outputMarkupPrompt(msg: string): void Protected Inherited RedlineTool  
parseAndRun(..._args: string[]): Promise<boolean> Inherited RedlineTool Run this instance of a tool using a series of string arguments.
pickElement(pt: Readonly<WritableXAndY>): undefined | @svgdotjs/svg.js.Element Inherited RedlineTool Find the topmost MarkupElement at the specified point in the markup view.
provideToolAssistance(mainInstrKey: string, singlePoint: booleanfalse): void Protected Inherited RedlineTool  
reloadToolSettingsProperties(): void Inherited RedlineTool Called by tool to inform UI to reload ToolSettings with new set of properties.
requireWriteableTarget(): boolean Inherited RedlineTool Called from isCompatibleViewport to check for a read only iModel, which is not a valid target for tools that create or modify elements.
run(..._args: any[]): Promise<boolean> Inherited RedlineTool Establish this tool as the active PrimitiveTool.
saveChanges(): Promise<void> Inherited RedlineTool If this tool is editing a briefcase, commits any elements that the tool has changed, supplying the tool name as the undo string.
setCurrentStyle(element: @svgdotjs/svg.js.Element, canBeFilled: boolean): void Protected Inherited RedlineTool  
setCurrentTextStyle(element: @svgdotjs/svg.js.Element): void Protected Inherited RedlineTool  
setupAndPromptForNextAction(): void Protected Inherited RedlineTool  
supplyToolSettingsProperties(): undefined | DialogItem[] Inherited RedlineTool Used to supply list of properties that can be used to generate ToolSettings.
syncToolSettingsProperties(syncData: DialogPropertySyncItem[]): void Inherited RedlineTool Called by tool to synchronize the UI with property changes made by tool.
testDecorationHit(_id: string): boolean Inherited RedlineTool Called to support operations on pickable decorations, like snapping.
register(namespace?: string): void Static Inherited RedlineTool Register this Tool class with the ToolRegistry.

Properties

Name Type Description
_numSides Protected number | undefined    
iconSpec Static string The icon for this Tool.  
toolId Static string The unique string that identifies this tool.  

Inherited properties

Name Type Inherited from Description
_minPoints Protected Inherited number RedlineTool  
_nRequiredPoints Protected Inherited number RedlineTool  
_points Protected Readonly Inherited Point3d[] RedlineTool  
briefcase Accessor Inherited ReadOnly undefined | BriefcaseConnection RedlineTool Get the briefcase on which this tool operates, if the tool has successfully installed and the target iModel is a briefcase.
description Accessor Inherited ReadOnly string RedlineTool Get the localized description string from this Tool's class
description Accessor Static Inherited ReadOnly string RedlineTool Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
flyover is returned.
englishKeyin Accessor Static Inherited ReadOnly string RedlineTool Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
flyover Accessor Inherited ReadOnly string RedlineTool Get the localized flyover string from this Tool's class
flyover Accessor Static Inherited ReadOnly string RedlineTool Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
keyin is returned.
hidden Static Inherited boolean RedlineTool If true, this Tool will not appear in the list from ToolRegistry.getToolList.
iconSpec Accessor Inherited ReadOnly string RedlineTool Get the iconSpec from this Tool's class.
iModel Accessor Inherited ReadOnly IModelConnection RedlineTool Get the iModel on which this tool operates.
isControlDown Accessor Inherited ReadOnly boolean RedlineTool Convenience method to check whether control key is currently down without needing a button event.
isDynamicsStarted Accessor Inherited ReadOnly boolean RedlineTool Call to find out if dynamics are currently active.
keyin Accessor Inherited ReadOnly string RedlineTool Get the localized keyin string from this Tool's class
keyin Accessor Static Inherited ReadOnly string RedlineTool Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
markup Inherited Markup RedlineTool  
maxArgs Accessor Static Inherited ReadOnly undefined | number RedlineTool The maximum number of arguments allowed by parseAndRun, or undefined if there is no maximum.
If subclasses override parseAndRun, they should also override this method to indicate the maximum
number of arguments their implementation expects.
minArgs Accessor Static Inherited ReadOnly number RedlineTool The minimum number of arguments allowed by parseAndRun. If subclasses override parseAndRun, they should also
override this method to indicate the minimum number of arguments their implementation expects. UI controls can use
this information to ensure the tool has enough information to execute.
namespace Static Inherited string RedlineTool The namespace that provides localized strings for this Tool.
receivedDownEvent Inherited boolean RedlineTool Used to avoid sending tools up events for which they did not receive the down event.
targetIsLocked Inherited boolean RedlineTool  
targetModelId Accessor Inherited undefined | string RedlineTool  
targetView Inherited Viewport | undefined RedlineTool The viewport within which the tool operates.
toolId Accessor Inherited ReadOnly string RedlineTool Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize
the keyin, description, etc. from the current locale.
toolKey Static Inherited string RedlineTool  

Defined in

Last Updated: 14 November, 2024