DistanceTool Class

Tool for measuring distances and placing Markups of them

Extends

Methods

Name Description
constructor(_arrowPos?: string): DistanceTool ctor for ArrowTool  
createMarkup(svgMarkup: @svgdotjs/svg.js.G, ev: BeButtonEvent, isDynamics: boolean): void Protected    
getFormattedDistance(distance: number): undefined | string Protected    
onDataButtonDown(ev: BeButtonEvent): Promise<EventHandled> Invoked when the data button is pressed.  
setupAndPromptForNextAction(): void Protected    
showPrompt(): void Protected    

Inherited methods

Name Inherited from Description
applyToolSettingPropertyChange(_updatedValue: DialogPropertySyncItem): Promise<boolean> Inherited ArrowTool Used to receive property changes from UI.
autoLockTarget(): void Inherited ArrowTool Called on data button down event to lock the tool to its current target model.
beginDynamics(): void Inherited ArrowTool Call to initialize dynamics mode.
bumpToolSetting(_settingIndex?: number): Promise<boolean> Inherited ArrowTool Used to "bump" the value of a tool setting.
changeLocateState(enableLocate: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void Inherited ArrowTool Helper method to keep the view cursor, display of locate circle, and coordinate lock overrides consistent with AccuSnap.isLocateEnabled and AccuSnap.isSnapEnabled.
changeToolSettingPropertyValue(syncItem: DialogPropertySyncItem): boolean Inherited ArrowTool Helper method for responding to a tool setting property value change by updating saved settings.
clearDynamicsMarkup(_isDynamics: boolean): void Protected Inherited ArrowTool  
decorate(_context: DecorateContext): void Inherited ArrowTool Called to allow an active tool to display non-element decorations in overlay mode.
decorateSuspended(_context: DecorateContext): void Inherited ArrowTool Called to allow a suspended tool to display non-element decorations in overlay mode.
endDynamics(): void Inherited ArrowTool Call to terminate dynamics mode.
exitTool(): Promise<void> Inherited ArrowTool  
filterHit(_hit: HitDetail, _out?: LocateResponse): Promise<LocateFilterStatus> Inherited ArrowTool Invoked to allow tools to filter which elements can be located.
getCurrentButtonEvent(ev: BeButtonEvent): void Inherited ArrowTool Fill the supplied button event from the current cursor location.
getDecorationGeometry(_hit: HitDetail): undefined | GeometryStreamProps Inherited ArrowTool Called to allow snapping to pickable decoration geometry.
getOrCreateArrowMarker(color: string): @svgdotjs/svg.js.Marker Protected Inherited ArrowTool  
getPrompt(): string Inherited ArrowTool Returns the prompt based on the tool's current state.
getToolSettingPropertyLocked(_property: DialogProperty<any>): undefined | DialogProperty<any> Inherited ArrowTool Override to return the property that is disabled/enabled if the supplied property is a lock property.
getToolTip(_hit: HitDetail): Promise<string | HTMLElement> Inherited ArrowTool Invoked before the locate tooltip is displayed to retrieve the information about the located element.
initializeToolSettingPropertyValues(properties: DialogProperty<any>[]): void Inherited ArrowTool Helper method to establish initial values for tool setting properties from saved settings.
initLocateElements(enableLocate?: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void Inherited ArrowTool Helper method for tools that need to locate existing elements.
isCompatibleViewport(vp: Viewport, isSelectedViewChange: boolean): boolean Inherited ArrowTool Determine whether the supplied Viewport is compatible with this tool.
isComplete(_ev: BeButtonEvent): boolean Protected Inherited ArrowTool  
isValidLocation(ev: BeButtonEvent, isButtonEvent: boolean): boolean Inherited ArrowTool Checks that the adjusted point from the supplied button event is within the project extents for spatial views.
onAdded(el: @svgdotjs/svg.js.Element): void Protected Inherited ArrowTool  
onCleanup(): Promise<void> Inherited ArrowTool Invoked when the tool becomes no longer active, to perform additional cleanup logic
onDataButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Inherited ArrowTool Invoked when the data button is released.
onDynamicFrame(_ev: BeButtonEvent, _context: DynamicsContext): void Inherited ArrowTool Called to allow Tool to display dynamic elements.
onInstall(): Promise<boolean> Inherited ArrowTool Override to execute additional logic when tool is installed.
onKeyTransition(_wentDown: boolean, _keyEvent: KeyboardEvent): Promise<EventHandled> Inherited ArrowTool Called when any key is pressed or released.
onMiddleButtonDown(_ev: BeButtonEvent): Promise<EventHandled> Inherited ArrowTool Invoked when the middle mouse button is pressed.
onMiddleButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Inherited ArrowTool Invoked when the middle mouse button is released.
onModifierKeyTransition(_wentDown: boolean, _modifier: BeModifierKeys, _event: KeyboardEvent): Promise<EventHandled> Inherited ArrowTool Called when Control, Shift, or Alt modifier keys are pressed or released.
onMouseEndDrag(ev: BeButtonEvent): Promise<EventHandled> Inherited ArrowTool Invoked when the button is released after onMouseStartDrag.
onMouseMotion(ev: BeButtonEvent): Promise<void> Inherited ArrowTool Invoked when the cursor is moving
onMouseStartDrag(_ev: BeButtonEvent): Promise<EventHandled> Inherited ArrowTool Invoked when the cursor begins moving while a button is depressed.
onMouseWheel(_ev: BeWheelEvent): Promise<EventHandled> Inherited ArrowTool Invoked when the mouse wheel moves.
onPostInstall(): Promise<void> Inherited ArrowTool Override to execute additional logic after tool becomes active
onRedoPreviousStep(): Promise<boolean> Inherited ArrowTool Called to reinstate to a previous tool state (ex.
onReinitialize(): Promise<void> Inherited ArrowTool Called to reset tool to initial state.
onResetButtonDown(_ev: BeButtonEvent): Promise<EventHandled> Inherited ArrowTool Invoked when the reset button is pressed.
onResetButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Inherited ArrowTool Invoked when the reset button is released.
onRestartTool(): Promise<void> Inherited ArrowTool Called when an external event may invalidate the current tool's state.
onSelectedViewportChanged(_previous: Viewport, current: Viewport): Promise<void> Inherited ArrowTool Called when active view changes.
onSuspend(): Promise<void> Inherited ArrowTool Notification of a ViewTool or InputCollector starting and this tool is being suspended.
onTouchCancel(ev: BeTouchEvent): Promise<void> Inherited ArrowTool Called when a touch point is interrupted in some way and needs to be dropped from the list of target touches.
onTouchComplete(ev: BeTouchEvent): Promise<void> Inherited ArrowTool Called when the last touch point is removed from the surface completing the current gesture.
onTouchEnd(_ev: BeTouchEvent): Promise<void> Inherited ArrowTool Called when user removes a touch point by lifting a finger or stylus from the surface.
onTouchMove(ev: BeTouchEvent): Promise<void> Inherited ArrowTool Called when a touch point moves along the surface.
onTouchMoveStart(ev: BeTouchEvent, startEv: BeTouchEvent): Promise<EventHandled> Inherited ArrowTool Called after at least one touch point has moved for an appreciable time and distance along the surface to not be considered a tap.
onTouchStart(_ev: BeTouchEvent): Promise<void> Inherited ArrowTool Called when user adds a touch point by placing a finger or stylus on the surface.
onTouchTap(_ev: BeTouchEvent): Promise<EventHandled> Inherited ArrowTool Called when touch point(s) are added and removed from a surface within a small time window without any touch point moving.
onUndoPreviousStep(): Promise<boolean> Inherited ArrowTool Called to reverse to a previous tool state (ex.
onUnsuspend(): Promise<void> Inherited ArrowTool Notification of a ViewTool or InputCollector exiting and this tool is being unsuspended.
outputMarkupPrompt(msg: string): void Protected Inherited ArrowTool  
parseAndRun(..._args: string[]): Promise<boolean> Inherited ArrowTool Run this instance of a tool using a series of string arguments.
pickElement(pt: Readonly<WritableXAndY>): undefined | @svgdotjs/svg.js.Element Inherited ArrowTool Find the topmost MarkupElement at the specified point in the markup view.
provideToolAssistance(mainInstrKey: string, singlePoint: booleanfalse): void Protected Inherited ArrowTool  
reloadToolSettingsProperties(): void Inherited ArrowTool Called by tool to inform UI to reload ToolSettings with new set of properties.
requireWriteableTarget(): boolean Inherited ArrowTool Called from isCompatibleViewport to check for a read only iModel, which is not a valid target for tools that create or modify elements.
run(..._args: any[]): Promise<boolean> Inherited ArrowTool Establish this tool as the active PrimitiveTool.
saveChanges(): Promise<void> Inherited ArrowTool If this tool is editing a briefcase, commits any elements that the tool has changed, supplying the tool name as the undo string.
setCurrentStyle(element: @svgdotjs/svg.js.Element, canBeFilled: boolean): void Protected Inherited ArrowTool  
setCurrentTextStyle(element: @svgdotjs/svg.js.Element): void Protected Inherited ArrowTool  
supplyToolSettingsProperties(): undefined | DialogItem[] Inherited ArrowTool Used to supply list of properties that can be used to generate ToolSettings.
syncToolSettingsProperties(syncData: DialogPropertySyncItem[]): void Inherited ArrowTool Called by tool to synchronize the UI with property changes made by tool.
testDecorationHit(_id: string): boolean Inherited ArrowTool Called to support operations on pickable decorations, like snapping.
register(namespace?: string): void Static Inherited ArrowTool Register this Tool class with the ToolRegistry.

Properties

Name Type Description
_startPointWorld Protected Readonly Point3d    
iconSpec Static string The icon for this Tool.  
toolId Static string The unique string that identifies this tool.  

Inherited properties

Name Type Inherited from Description
_arrowPos Protected Inherited string | undefined ArrowTool "start", "end", or "both".
_minPoints Protected Inherited number ArrowTool  
_nRequiredPoints Protected Inherited number ArrowTool  
_points Protected Readonly Inherited Point3d[] ArrowTool  
briefcase Accessor Inherited ReadOnly undefined | BriefcaseConnection ArrowTool Get the briefcase on which this tool operates, if the tool has successfully installed and the target iModel is a briefcase.
description Accessor Inherited ReadOnly string ArrowTool Get the localized description string from this Tool's class
description Accessor Static Inherited ReadOnly string ArrowTool Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
flyover is returned.
englishKeyin Accessor Static Inherited ReadOnly string ArrowTool Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
flyover Accessor Inherited ReadOnly string ArrowTool Get the localized flyover string from this Tool's class
flyover Accessor Static Inherited ReadOnly string ArrowTool Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
keyin is returned.
hidden Static Inherited boolean ArrowTool If true, this Tool will not appear in the list from ToolRegistry.getToolList.
iconSpec Accessor Inherited ReadOnly string ArrowTool Get the iconSpec from this Tool's class.
iModel Accessor Inherited ReadOnly IModelConnection ArrowTool Get the iModel on which this tool operates.
isControlDown Accessor Inherited ReadOnly boolean ArrowTool Convenience method to check whether control key is currently down without needing a button event.
isDynamicsStarted Accessor Inherited ReadOnly boolean ArrowTool Call to find out if dynamics are currently active.
keyin Accessor Inherited ReadOnly string ArrowTool Get the localized keyin string from this Tool's class
keyin Accessor Static Inherited ReadOnly string ArrowTool Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
markup Inherited Markup ArrowTool  
maxArgs Accessor Static Inherited ReadOnly undefined | number ArrowTool The maximum number of arguments allowed by parseAndRun, or undefined if there is no maximum.
If subclasses override parseAndRun, they should also override this method to indicate the maximum
number of arguments their implementation expects.
minArgs Accessor Static Inherited ReadOnly number ArrowTool The minimum number of arguments allowed by parseAndRun. If subclasses override parseAndRun, they should also
override this method to indicate the minimum number of arguments their implementation expects. UI controls can use
this information to ensure the tool has enough information to execute.
namespace Static Inherited string ArrowTool The namespace that provides localized strings for this Tool.
receivedDownEvent Inherited boolean ArrowTool Used to avoid sending tools up events for which they did not receive the down event.
targetIsLocked Inherited boolean ArrowTool  
targetModelId Accessor Inherited undefined | string ArrowTool  
targetView Inherited Viewport | undefined ArrowTool The viewport within which the tool operates.
toolId Accessor Inherited ReadOnly string ArrowTool Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize
the keyin, description, etc. from the current locale.
toolKey Static Inherited string ArrowTool  

Defined in

Last Updated: 14 November, 2024