SolidPrimitive Class
Base class for SolidPrimitive variants.
- The base class holds capped flag for all derived classes.
Extends
Extended by
Methods
Name | Description | |
---|---|---|
constructor(capped: boolean): SolidPrimitive Protected | ||
constantVSection(_vFraction: number): undefined | CurveCollection Abstract | Return a cross section at specified vFraction. | |
getConstructiveFrame(): undefined | Transform Abstract | Return a Transform from the local system of the solid to world. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
clone(): undefined | GeometryQuery Abstract | GeometryQuery | Return a clone |
cloneTransformed(transform: Transform): undefined | GeometryQuery Abstract | GeometryQuery | Return a transformed clone. |
dispatchToGeometryHandler(handler: GeometryHandler): any Abstract | GeometryQuery | Double Dispatch call pattern. |
extendRange(rangeToExtend: Range3d, transform?: Transform): void Abstract | GeometryQuery | Extend rangeToExtend by the range of this geometry multiplied by the transform . |
isAlmostEqual(other: GeometryQuery): boolean | GeometryQuery | Test for exact structure and nearly identical geometry. |
isSameGeometryClass(other: GeometryQuery): boolean Abstract | GeometryQuery | Test if (other instanceof this.Type) . |
range(transform?: Transform, result?: Range3d): Range3d | GeometryQuery | Return the range of the entire GeometryQuery tree. |
tryTransformInPlace(transform: Transform): boolean Abstract | GeometryQuery | Attempt to transform in place. |
tryTranslateInPlace(dx: number, dy: number0.0, dz: number0.0): boolean | GeometryQuery | Try to move the geometry by dx,dy,dz. |
areAlmostEqual(a: GeometryQuery, b: GeometryQuery): boolean Static | GeometryQuery | Apply instance method isAlmostEqual if both are defined. |
Properties
Name | Type | Description | |
---|---|---|---|
_capped Protected | boolean | flag indicating whether cap region is considered closed (i.e. | |
capped Accessor | boolean | Whether this is a capped solid | |
geometryCategory Readonly | "solid" | String name for schema properties | |
isClosedVolume Accessor Abstract ReadOnly | boolean | ||
solidPrimitiveType Abstract Readonly | SolidPrimitiveType | String name for schema properties |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
children Accessor ReadOnly | undefined | GeometryQuery[] | GeometryQuery | Return GeometryQuery children for recursive queries. * leaf classes do not need to implement. |
Defined in
- solid/SolidPrimitive.ts Line 46
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.