GeometryHandler Class
GeometryHandler
defines the base abstract methods for double-dispatch geometry computation.
- User code that wants to handle one or all of the commonly known geometry types implements a handler class.
- User code that does not handle all types is most likely to start with
NullGeometryHandler
, which will provide No-action implementations for all types.
Extended by
Methods
Name | Description | |
---|---|---|
constructor(): GeometryHandler | ||
handleAkimaCurve3d(g: AkimaCurve3d): any Abstract | Handle strongly typed AkimaCurve3d | |
handleArc3d(g: Arc3d): any Abstract | Handle strongly typed Arc3d | |
handleBSplineCurve3d(g: BSplineCurve3d): any Abstract | Handle strongly typed BSplineCurve3d | |
handleBSplineCurve3dH(g: BSplineCurve3dH): any Abstract | Handle strongly typed BSplineCurve3dH | |
handleBSplineSurface3d(g: BSplineSurface3d): any Abstract | Handle strongly typed BSplineSurface3d | |
handleBSplineSurface3dH(g: BSplineSurface3dH): any Abstract | Handle strongly typed BSplineSurface3dH | |
handleBagOfCurves(g: BagOfCurves): any | Handle strongly typed BagOfCurves (base class method calls handleCurveCollection) | |
handleBezierCurve3d(g: BezierCurve3d): any Abstract | Handle strongly typed BezierCurve3d | |
handleBezierCurve3dH(g: BezierCurve3dH): any Abstract | Handle strongly typed BezierCurve3dH | |
handleBox(g: Box): any Abstract | Handle strongly typed Box | |
handleCone(g: Cone): any Abstract | Handle strongly typed Cone | |
handleCoordinateXYZ(g: CoordinateXYZ): any Abstract | Handle strongly typed CoordinateXYZ | |
handleCurveChainWithDistanceIndex(g: CurveChainWithDistanceIndex): any | Handle strongly typed CurveChainWithDistanceIndex (base class method calls handlePath or handleLoop) | |
handleCurveCollection(_g: CurveCollection): any | Handle strongly typed CurveCollection | |
handleIndexedPolyface(g: IndexedPolyface): any Abstract | Handle strongly typed IndexedPolyface | |
handleInterpolationCurve3d(g: InterpolationCurve3d): any Abstract | Handle strongly typed InterpolationCurve3d | |
handleLineSegment3d(g: LineSegment3d): any Abstract | Handle strongly typed LineSegment3d | |
handleLineString3d(g: LineString3d): any Abstract | Handle strongly typed LineString3d | |
handleLinearSweep(g: LinearSweep): any Abstract | Handle strongly typed LinearSweep | |
handleLoop(g: Loop): any | Handle strongly typed Loop (base class method calls handleCurveCollection) | |
handleParityRegion(g: ParityRegion): any | Handle strongly typed ParityRegion (base class method calls handleCurveCollection) | |
handlePath(g: Path): any | Handle strongly typed Path (base class method calls handleCurveCollection) | |
handlePointString3d(g: PointString3d): any Abstract | Handle strongly typed PointString3d | |
handleRotationalSweep(g: RotationalSweep): any Abstract | Handle strongly typed RotationalSweep | |
handleRuledSweep(g: RuledSweep): any Abstract | Handle strongly typed RuledSweep | |
handleSphere(g: Sphere): any Abstract | Handle strongly typed Sphere | |
handleTorusPipe(g: TorusPipe): any Abstract | Handle strongly typed TorusPipe | |
handleTransitionSpiral(g: TransitionSpiral3d): any Abstract | handle strongly typed TransitionSpiral3d | |
handleUnionRegion(g: UnionRegion): any | Handle strongly typed UnionRegion (base class method calls handleCurveCollection) |
Defined in
- geometry3d/GeometryHandler.ts Line 51
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.