RecurseToCurvesGeometryHandler Class
Implement GeometryHandler methods, but override handleCurveCollection
so that all methods
that operate on a CurveCollection recurse to their children.
Extends
Extended by
Methods
Name | Description | |
---|---|---|
constructor(): RecurseToCurvesGeometryHandler | ||
handleAkimaCurve3d(_g: AkimaCurve3d): any | No-action implementation | |
handleArc3d(_g: Arc3d): any | No-action implementation | |
handleBSplineCurve3d(_g: BSplineCurve3d): any | No-action implementation | |
handleBSplineCurve3dH(_g: BSplineCurve3dH): any | No-action implementation | |
handleBSplineSurface3d(_g: BSplineSurface3d): any | No-action implementation | |
handleBSplineSurface3dH(_g: BSplineSurface3dH): any | No-action implementation | |
handleBezierCurve3d(_g: BezierCurve3d): any | No-action implementation | |
handleBezierCurve3dH(_g: BezierCurve3dH): any | No-action implementation | |
handleBox(_g: Box): any | No-action implementation | |
handleChildren(g: GeometryQuery): any | Invoke child.dispatchToGeometryHandler(this) for each child in the array returned by the query g.children |
|
handleCone(_g: Cone): any | No-action implementation | |
handleCoordinateXYZ(_g: CoordinateXYZ): any | No-action implementation | |
handleCurveCollection(g: CurveCollection): any | Recurse to children | |
handleIndexedPolyface(_g: IndexedPolyface): any | No-action implementation | |
handleInterpolationCurve3d(_g: InterpolationCurve3d): any | No-action implementation | |
handleLineSegment3d(_g: LineSegment3d): any | No-action implementation | |
handleLineString3d(_g: LineString3d): any | No-action implementation | |
handleLinearSweep(_g: LinearSweep): any | No-action implementation | |
handlePointString3d(_g: PointString3d): any | No-action implementation | |
handleRotationalSweep(_g: RotationalSweep): any | No-action implementation | |
handleRuledSweep(_g: RuledSweep): any | No-action implementation | |
handleSphere(_g: Sphere): any | No-action implementation | |
handleTorusPipe(_g: TorusPipe): any | No-action implementation | |
handleTransitionSpiral(_g: TransitionSpiral3d): any | No-action implementation |
Inherited methods
Name | Inherited from | Description |
---|---|---|
handleBagOfCurves(g: BagOfCurves): any | GeometryHandler | Handle strongly typed BagOfCurves (base class method calls handleCurveCollection) |
handleCurveChainWithDistanceIndex(g: CurveChainWithDistanceIndex): any | GeometryHandler | Handle strongly typed CurveChainWithDistanceIndex (base class method calls handlePath or handleLoop) |
handleLoop(g: Loop): any | GeometryHandler | Handle strongly typed Loop (base class method calls handleCurveCollection) |
handleParityRegion(g: ParityRegion): any | GeometryHandler | Handle strongly typed ParityRegion (base class method calls handleCurveCollection) |
handlePath(g: Path): any | GeometryHandler | Handle strongly typed Path (base class method calls handleCurveCollection) |
handleUnionRegion(g: UnionRegion): any | GeometryHandler | Handle strongly typed UnionRegion (base class method calls handleCurveCollection) |
Defined in
- geometry3d/GeometryHandler.ts Line 258
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.