CoordinateXYZ Class
A Coordinate is a Point3d with supporting methods from the GeometryQuery abstraction.
Extends
Methods
Name | Description | |
---|---|---|
clone(): undefined | GeometryQuery | Return a clone. | |
cloneTransformed(transform: Transform): undefined | GeometryQuery | Return a transformed clone. | |
dispatchToGeometryHandler(handler: GeometryHandler): any | Second step of double dispatch: call handler.handleCoordinateXYZ(this) |
|
extendRange(rangeToExtend: Range3d, transform?: Transform): void | Extend rangeToExtend to include this point (optionally transformed). |
|
isAlmostEqual(other: GeometryQuery): boolean | Test for exact structure and nearly identical geometry. | |
isSameGeometryClass(other: GeometryQuery): boolean | Test if (other instanceof Coordinate). | |
range(): Range3d | Return the range of the point. | |
tryTransformInPlace(transform: Transform): boolean | Apply transform to the Coordinate's point. | |
create(point: Point3d): CoordinateXYZ Static | Create a new CoordinateXYZ containing a CLONE of point. | |
createXYZ(x: number0, y: number0, z: number0): CoordinateXYZ Static | Create a new CoordinateXYZ. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
tryTranslateInPlace(dx: number, dy: number0.0, dz: number0.0): boolean | GeometryQuery | Try to move the geometry by dx,dy,dz. |
areAlmostEqual(a: GeometryQuery, b: GeometryQuery): boolean Static | GeometryQuery | Apply instance method isAlmostEqual if both are defined. |
Properties
Name | Type | Description | |
---|---|---|---|
geometryCategory Readonly | "point" | String name for interface properties. | |
point Accessor ReadOnly | Point3d | Return a (REFERENCE TO) the coordinate data. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
children Accessor ReadOnly | undefined | GeometryQuery[] | GeometryQuery | Return GeometryQuery children for recursive queries. * leaf classes do not need to implement. |
Defined in
- curve/CoordinateXYZ.ts Line 18
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.