tryTransformInPlace MethodAbstract
Attempt to transform in place.
- LineSegment3d, Arc3d, LineString3d, BsplineCurve3d always succeed.
- Some geometry types may fail if scaling is non-uniform.
tryTransformInPlace(transform: Transform): boolean
Parameter | Type | Description |
---|---|---|
transform | Transform |
Returns - boolean
Defined in
- curve/GeometryQuery.ts Line 73
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.