ViewRedoTool Class

A tool that performs view redo operation. An application could also just call Viewport.doRedo directly, creating a ViewTool isn't required.

Extends

Methods

Name Description
constructor(viewport?: ScreenViewport): ViewRedoTool    
onPostInstall(): Promise<void> Override to execute additional logic after tool becomes active  

Inherited methods

Name Inherited from Description
applyToolSettingPropertyChange(_updatedValue: DialogPropertySyncItem): Promise<boolean> Inherited ViewTool Used to receive property changes from UI.
beginDynamics(): void Inherited ViewTool Call to initialize dynamics mode.
beginDynamicUpdate(): void Inherited ViewTool  
bumpToolSetting(_settingIndex?: number): Promise<boolean> Inherited ViewTool Used to "bump" the value of a tool setting.
changeLocateState(enableLocate: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void Inherited ViewTool Helper method to keep the view cursor, display of locate circle, and coordinate lock overrides consistent with isLocateEnabled and isSnapEnabled.
changeToolSettingPropertyValue(syncItem: DialogPropertySyncItem): boolean Inherited ViewTool Helper method for responding to a tool setting property value change by updating saved settings.
decorate(_context: DecorateContext): void Inherited ViewTool Called to allow an active tool to display non-element decorations in overlay mode.
decorateSuspended(_context: DecorateContext): void Inherited ViewTool Called to allow a suspended tool to display non-element decorations in overlay mode.
endDynamics(): void Inherited ViewTool Call to terminate dynamics mode.
endDynamicUpdate(): void Inherited ViewTool  
exitTool(): Promise<void> Inherited ViewTool Do not override.
filterHit(_hit: HitDetail, _out?: LocateResponse): Promise<LocateFilterStatus> Inherited ViewTool Invoked to allow tools to filter which elements can be located.
getCurrentButtonEvent(ev: BeButtonEvent): void Inherited ViewTool Fill the supplied button event from the current cursor location.
getDecorationGeometry(_hit: HitDetail): undefined | GeometryStreamProps Inherited ViewTool Called to allow snapping to pickable decoration geometry.
getToolSettingPropertyLocked(_property: DialogProperty<any>): undefined | DialogProperty<any> Inherited ViewTool Override to return the property that is disabled/enabled if the supplied property is a lock property.
getToolTip(_hit: HitDetail): Promise<string | HTMLElement> Inherited ViewTool Invoked before the locate tooltip is displayed to retrieve the information about the located element.
initializeToolSettingPropertyValues(properties: DialogProperty<any>[]): void Inherited ViewTool Helper method to establish initial values for tool setting properties from saved settings.
initLocateElements(enableLocate: booleantrue, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void Inherited ViewTool Helper method for tools that need to locate existing elements.
isCompatibleViewport(_vp: ScreenViewport, _isSelectedViewChange: boolean): boolean Inherited ViewTool  
isValidLocation(_ev: BeButtonEvent, _isButtonEvent: boolean): boolean Inherited ViewTool  
onCleanup(): Promise<void> Inherited ViewTool Invoked when the tool becomes no longer active, to perform additional cleanup logic
onDataButtonDown(_ev: BeButtonEvent): Promise<EventHandled> Inherited ViewTool Invoked when the data button is pressed.
onDataButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Inherited ViewTool Invoked when the data button is released.
onDynamicFrame(_ev: BeButtonEvent, _context: DynamicsContext): void Inherited ViewTool Called to allow Tool to display dynamic elements.
onInstall(): Promise<boolean> Inherited ViewTool Override to execute additional logic when tool is installed.
onKeyTransition(_wentDown: boolean, _keyEvent: KeyboardEvent): Promise<EventHandled> Inherited ViewTool Called when any key is pressed or released.
onMiddleButtonDown(_ev: BeButtonEvent): Promise<EventHandled> Inherited ViewTool Invoked when the middle mouse button is pressed.
onMiddleButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Inherited ViewTool Invoked when the middle mouse button is released.
onModifierKeyTransition(_wentDown: boolean, _modifier: BeModifierKeys, _event: KeyboardEvent): Promise<EventHandled> Inherited ViewTool Called when Control, Shift, or Alt modifier keys are pressed or released.
onMouseEndDrag(ev: BeButtonEvent): Promise<EventHandled> Inherited ViewTool Invoked when the button is released after onMouseStartDrag.
onMouseMotion(_ev: BeButtonEvent): Promise<void> Inherited ViewTool Invoked when the cursor is moving
onMouseStartDrag(_ev: BeButtonEvent): Promise<EventHandled> Inherited ViewTool Invoked when the cursor begins moving while a button is depressed.
onMouseWheel(_ev: BeWheelEvent): Promise<EventHandled> Inherited ViewTool Invoked when the mouse wheel moves.
onReinitialize(): Promise<void> Inherited ViewTool Override Call to reset tool to initial state
onResetButtonDown(_ev: BeButtonEvent): Promise<EventHandled> Inherited ViewTool Invoked when the reset button is pressed.
onResetButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Inherited ViewTool Invoked when the reset button is released.
onSelectedViewportChanged(_previous: ScreenViewport, _current: ScreenViewport): void Inherited ViewTool Called when active view changes.
onSuspend(): Promise<void> Inherited ViewTool Notification of a ViewTool or InputCollector starting and this tool is being suspended.
onTouchCancel(_ev: BeTouchEvent): Promise<void> Inherited ViewTool Called when a touch point is interrupted in some way and needs to be dropped from the list of target touches.
onTouchComplete(_ev: BeTouchEvent): Promise<void> Inherited ViewTool Called when the last touch point is removed from the surface completing the current gesture.
onTouchEnd(_ev: BeTouchEvent): Promise<void> Inherited ViewTool Called when user removes a touch point by lifting a finger or stylus from the surface.
onTouchMove(_ev: BeTouchEvent): Promise<void> Inherited ViewTool Called when a touch point moves along the surface.
onTouchMoveStart(_ev: BeTouchEvent, _startEv: BeTouchEvent): Promise<EventHandled> Inherited ViewTool Called after at least one touch point has moved for an appreciable time and distance along the surface to not be considered a tap.
onTouchStart(_ev: BeTouchEvent): Promise<void> Inherited ViewTool Called when user adds a touch point by placing a finger or stylus on the surface.
onTouchTap(_ev: BeTouchEvent): Promise<EventHandled> Inherited ViewTool Called when touch point(s) are added and removed from a surface within a small time window without any touch point moving.
onUnsuspend(): Promise<void> Inherited ViewTool Notification of a ViewTool or InputCollector exiting and this tool is being unsuspended.
parseAndRun(..._args: string[]): Promise<boolean> Inherited ViewTool Run this instance of a tool using a series of string arguments.
reloadToolSettingsProperties(): void Inherited ViewTool Called by tool to inform UI to reload ToolSettings with new set of properties.
run(..._args: any[]): Promise<boolean> Inherited ViewTool Run this instance of a Tool.
supplyToolSettingsProperties(): undefined | DialogItem[] Inherited ViewTool Used to supply list of properties that can be used to generate ToolSettings.
syncToolSettingsProperties(syncData: DialogPropertySyncItem[]): void Inherited ViewTool Called by tool to synchronize the UI with property changes made by tool.
testDecorationHit(_id: string): boolean Inherited ViewTool Called to support operations on pickable decorations, like snapping.
register(namespace?: string): void Static Inherited ViewTool Register this Tool class with the ToolRegistry.
showPrompt(prompt: string): void Static Inherited ViewTool  
translate(val: string): string Static Inherited ViewTool  

Properties

Name Type Description
iconSpec Static string The icon for this Tool.  
toolId Static string The unique string that identifies this tool.  

Inherited properties

Name Type Inherited from Description
description Accessor Inherited ReadOnly string ViewTool Get the localized description string from this Tool's class
description Accessor Static Inherited ReadOnly string ViewTool Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
flyover is returned.
englishKeyin Accessor Static Inherited ReadOnly string ViewTool Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
flyover Accessor Inherited ReadOnly string ViewTool Get the localized flyover string from this Tool's class
flyover Accessor Static Inherited ReadOnly string ViewTool Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
keyin is returned.
hidden Static Inherited boolean ViewTool If true, this Tool will not appear in the list from getToolList.
iconSpec Accessor Inherited ReadOnly string ViewTool Get the iconSpec from this Tool's class.
inDynamicUpdate Inherited boolean ViewTool  
isControlDown Accessor Inherited ReadOnly boolean ViewTool Convenience method to check whether control key is currently down without needing a button event.
isDynamicsStarted Accessor Inherited ReadOnly boolean ViewTool Call to find out if dynamics are currently active.
keyin Accessor Inherited ReadOnly string ViewTool Get the localized keyin string from this Tool's class
keyin Accessor Static Inherited ReadOnly string ViewTool Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
maxArgs Accessor Static Inherited ReadOnly undefined | number ViewTool The maximum number of arguments allowed by parseAndRun, or undefined if there is no maximum.
If subclasses override parseAndRun, they should also override this method to indicate the maximum
number of arguments their implementation expects.
minArgs Accessor Static Inherited ReadOnly number ViewTool The minimum number of arguments allowed by parseAndRun. If subclasses override parseAndRun, they should also
override this method to indicate the minimum number of arguments their implementation expects. UI controls can use
this information to ensure the tool has enough information to execute.
namespace Static Inherited string ViewTool The namespace that provides localized strings for this Tool.
receivedDownEvent Inherited boolean ViewTool Used to avoid sending tools up events for which they did not receive the down event.
toolId Accessor Inherited ReadOnly string ViewTool Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize
the keyin, description, etc. from the current locale.
viewport Inherited ScreenViewport | undefined ViewTool  

Defined in

Last Updated: 14 November, 2024