IModelAppOptions Interface
Options that can be supplied to startup to customize frontend behavior.
Properties
Name | Type | Description | |
---|---|---|---|
accuDraw | AccuDraw | undefined | If present, supplies the AccuDraw for this session. | |
accuSnap | AccuSnap | undefined | If present, supplies the AccuSnap for this session. | |
applicationId | string | undefined | If present, supplies the Id of this application. | |
applicationVersion | string | undefined | If present, supplies the version of this application. | |
authorizationClient | AuthorizationClient | undefined | The AuthorizationClient used to obtain AccessTokens. | |
hubAccess | FrontendHubAccess | undefined | If present, supplies the FrontendHubAccess for this session. | |
localization | Localization | undefined | If present, supplies the Localization for this session. | |
mapLayerOptions | MapLayerOptions | undefined | If present, supplies Map Layer Options for this session such as Azure Access Keys | |
notifications | NotificationManager | undefined | If present, supplies the NotificationManager for this session. | |
publicPath | string | undefined | If present, overrides where public assets are fetched. | |
realityDataAccess | RealityDataAccess | undefined | ||
renderSys | RenderSystem | RenderSystem.Options | If present, supplies an implementation of the render system, or options for initializing the default render system. | |
rpcInterfaces | RpcInterfaceDefinition<RpcInterface>[] | undefined | Deprecated | |
security | FrontendSecurityOptions | undefined | If present, supplies security options for the frontend. | |
tentativePoint | TentativePoint | undefined | If present, supplies the TentativePoint for this session. | |
tileAdmin | TileAdmin.Props | undefined | If present, supplies the properties with which to initialize the TileAdmin for this session. | |
toolAdmin | ToolAdmin | undefined | If present, supplies the ToolAdmin for this session. | |
uiAdmin | UiAdmin | undefined | If present, supplies the UiAdmin for this session. | |
userPreferences | UserPreferencesAccess | undefined | If present, supplies the UserPreferencesAccess for this session. | |
viewManager | ViewManager | undefined | If present, supplies the ViewManager for this session. |
Defined in
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.