NotificationManager Class
The NotificationManager controls the interaction with the user for prompts, error messages, and alert dialogs. Implementations of the NotificationManager may present the information in different ways. For example, in non-interactive sessions, these messages may be saved to a log file or simply discarded.
Implements
Methods
Name | Description | |
---|---|---|
constructor(): NotificationManager | ||
_showToolTip(_htmlElement: HTMLElement, _message: string | HTMLElement, _location?: Readonly<WritableXAndY>, _options?: ToolTipOptions): void Protected | Implement to display a tooltip message at the specified location. | |
clearToolTip(): void | Clear the tooltip if it is currently open. | |
Close message created with InputField. | ||
Close message created with Pointer. | ||
Displays an input field notification message. | ||
Displays a notification message. | ||
End an activity message. | ||
Output a MessageBox and wait for response from the user. | ||
openToolTip(htmlElement: HTMLElement, message: string | HTMLElement, location?: Readonly<WritableXAndY>, options?: ToolTipOptions): void | Show a tooltip window. | |
Output an activity message to the user. | ||
Output a message and/or alert to the user. | ||
outputPrompt(_prompt: string): void | Output a localized prompt to the user. | |
outputPromptByKey(key: string): void | Output a prompt, given a localization key. | |
setToolAssistance(instructions: ToolAssistanceInstructions): void | Setup tool assistance instructions for a tool. | |
Set up for activity messages. | ||
Update message position created with Pointer. |
Properties
Name | Type | Description | |
---|---|---|---|
isToolTipOpen Accessor ReadOnly | boolean | Return true if the tooltip is currently open. | |
isToolTipSupported Accessor ReadOnly | boolean | Return true if _showTooltip has an implementation and will display a tooltip. | |
toolTipLocation Readonly | Point2d |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.