NotifyMessageDetails Class
Describes a message to be displayed to the user.
Methods
Name | Description | |
---|---|---|
constructor(priority: OutputMessagePriority, briefMessage: string | HTMLElement, detailedMessage?: string | HTMLElement, msgType: OutputMessageTypeOutputMessageType.Toast, openAlert: OutputMessageAlertOutputMessageAlert.None): NotifyMessageDetails | Constructor | |
setInputFieldTypeDetails(inputField: HTMLElement): void | Set OutputMessageType.InputField message details. | |
setPointerTypeDetails(viewport: HTMLElement, displayPoint: Readonly<WritableXAndY>, relativePosition: RelativePositionRelativePosition.TopRight): void | Set OutputMessageType.Pointer message details. |
Properties
Name | Type | Description | |
---|---|---|---|
string | HTMLElement | A short message that conveys the simplest explanation of the issue. | ||
string | HTMLElement | An optional comprehensive message that explains the issue in detail and potentially offers a solution. | ||
displayPoint | Point2d | undefined | ||
displayTime | BeDuration | ||
inputField | HTMLElement | undefined | ||
msgType | OutputMessageType | The type of message. | |
openAlert | OutputMessageAlert | Whether an alert box should be displayed or not, and if so what kind. | |
priority | OutputMessagePriority | The priority this message should be accorded by the NotificationManager. | |
relativePosition | RelativePosition | ||
viewport | HTMLElement | undefined |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.