ActivityMessageDetails Class
Specifies the details of an activity message to be displayed to the user.
Methods
Name | Description | |
---|---|---|
constructor(showProgressBar: boolean, showPercentInMessage: boolean, supportsCancellation: boolean, showDialogInitially: booleantrue): ActivityMessageDetails | ||
onActivityCancelled(): void | Called from NotificationAdmin when the user cancels the activity. | |
onActivityCompleted(): void | Called from NotificationAdmin when the activity completes successfully. |
Properties
Name | Type | Description | |
---|---|---|---|
showDialogInitially | boolean | Indicates whether to show the activity message dialog initially. | |
boolean | Indicates whether to show the percentage complete in the activity message text. | ||
showProgressBar | boolean | Indicates whether to show the progress bar in the activity message dialog. | |
supportsCancellation | boolean | Indicates whether to show the Cancel button, giving the user the ability to cancel the operation. | |
wasCancelled | boolean |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.