TileAdmin.Props Interface
Describes the configuration of the TileAdmin.
@see TileAdmin.create to specify the configuration at startup time.
@note Many of these settings serve as "feature gates" introduced alongside new, potentially experimental features.
Over time, as a feature is tested and proven, their relevance wanes, and the feature becomes enabled by default.
Such properties should be flagged as beta
and removed or rendered non-operational once the feature itself is considered
stable.
Properties
Name | Type | Description | |
---|---|---|---|
alwaysRequestEdges | boolean | undefined | If true, when requesting tile content, edges will always be requested, even if they are not required for the view. | |
cesiumIonKey | string | undefined | An API key that can be used to access content from Cesium ION like terrain meshes and OpenStreetMap Buildings meshes. | |
defaultTileSizeModifier | number | undefined | A default multiplier applied to the size in pixels of a Tile during tile selection for any Viewport. | |
enableExternalTextures | boolean | undefined | If true, during tile generation the backend will not embed all texture image data in the tile content. | |
enableFrontendScheduleScripts | boolean | undefined | If true, when applying a schedule script to a view, ordinary tiles will be requested and then reprocessed on the frontend to align with the script's | |
enableImprovedElision | boolean | undefined | If true, during tile generation the backend will perform tighter intersection tests to more accurately identify empty sub-volumes. | |
enableIndexedEdges | boolean | undefined | If true - and WebGL 2 is supported by the RenderSystem - when tiles containing edges are requested, request that they produce | |
enableInstancing | boolean | undefined | If true, tiles may represent repeated geometry as sets of instances. | |
generateAllPolyfaceEdges | boolean | undefined | If true then if a Polyface lacks edge visibility information, the display system will display the edges of all of its faces. | |
gpuMemoryLimits | GpuMemoryLimit | GpuMemoryLimits | Defines optional limits on the total amount of GPU memory allocated to Tile contents. | |
ignoreAreaPatterns | boolean | undefined | If true, during tile generation the backend will omit geometry for area patterns. | |
minimumSpatialTolerance | number | undefined | If defined and greater than zero, specifies the minimum chord tolerance in meters of a tile. | |
mobileRealityTileMinToleranceRatio | number | undefined | Nominally the error on screen size of a reality tile. | |
retryInterval | number | undefined | The interval in milliseconds at which a request for tile content will be retried until a response is received. | |
tileExpirationTime | number | undefined | The minimum number of seconds to keep a Tile in memory after it has become unused. | |
tileStorage | FrontendStorage | undefined | The client side storage implementation of @itwin/object-storage-core to use for retrieving tiles from tile cache. | |
tileTreeExpirationTime | number | undefined | The minimum number of seconds to keep a TileTree in memory after it has become disused. | |
useLargerTiles | boolean | undefined | Produce tiles that are larger in screen pixels to reduce the number of tiles requested and drawn by the scene. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.