MapLayerOptions Interface
Options supplied at startup via mapLayerOptions to specify access keys for various map layer formats. 'BingMaps' must have it's key value set to 'key' 'MapboxImagery' must have it's key value set to 'access_token'
Properties
Name | Type | Description | |
---|---|---|---|
AzureMaps | MapLayerKey | undefined | Access key for Azure Maps in the format { key: "subscription-key", value: "your-azure-maps-key" } . |
|
BingMaps | MapLayerKey | undefined | Access key for Bing Maps in the format { key: "key", value: "your-bing-maps-key" } . |
|
MapboxImagery | MapLayerKey | undefined | Access key for Mapbox in the format { key: "access_token", value: "your-mapbox-key" } . |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.