ViewStateProps Interface
Returned from IModelDb.Views.getViewStateData.
Properties
Name | Type | Description | |
---|---|---|---|
categorySelectorProps | CategorySelectorProps | ||
displayStyleProps | DisplayStyleProps | ||
modelExtents | Range3dProps | undefined | For a DrawingViewState, the extents of the DrawingModel, used for determining the upper limits of the view's extents. | |
modelSelectorProps | ModelSelectorProps | undefined | ||
sectionDrawing | SectionDrawingViewProps | undefined | Information about the SectionDrawing relevant to displaying a drawing view. | |
sheetAttachments | Id64Array | undefined | The Ids of the ViewAttachments contained within the SheetModel, if this is a sheet view. | |
sheetProps | SheetProps | undefined | Sheet-specific properties, if this is a view of a SheetModel. | |
viewDefinitionProps | ViewDefinitionProps |
Defined in
- core/common/src/ViewProps.ts Line 101
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.