SheetProps Interface
Properties of a Sheet.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
attachments | string[] | undefined | ||
height | number | undefined | ||
scale | number | undefined | ||
sheetTemplate | string | undefined | ||
width | number | undefined |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName | string | ElementProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
code | CodeProps | ElementProps | The Code for this element |
federationGuid | string | undefined | ElementProps | A FederationGuid assigned to this element. |
id | string | undefined | ElementProps | The Id of the entity. |
isInstanceOfEntity Readonly | undefined | undefined | ElementProps | A non-existent property used to discriminate between EntityProps and Entity. |
jsonProperties | any | undefined | ElementProps | Optional json properties of this element. |
model | string | ElementProps | The Id of the Model containing this element |
parent | RelatedElementProps | undefined | ElementProps | The Parent of this element, if defined. |
userLabel | string | undefined | ElementProps | A user-assigned label for this element. |
Defined in
- core/common/src/ElementProps.ts Line 317
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.