CategorySelectorProps Interface
Properties that define a CategorySelector
Extends
Properties
Name | Type | Description | |
---|---|---|---|
categories | Id64Array |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName | string | DefinitionElementProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
code | CodeProps | DefinitionElementProps | The Code for this element |
federationGuid | string | undefined | DefinitionElementProps | A FederationGuid assigned to this element. |
id | string | undefined | DefinitionElementProps | The Id of the entity. |
isInstanceOfEntity Readonly | undefined | undefined | DefinitionElementProps | A non-existent property used to discriminate between EntityProps and Entity. |
isPrivate | boolean | undefined | DefinitionElementProps | |
jsonProperties | any | undefined | DefinitionElementProps | Optional json properties of this element. |
model | string | DefinitionElementProps | The Id of the Model containing this element |
parent | RelatedElementProps | undefined | DefinitionElementProps | The Parent of this element, if defined. |
userLabel | string | undefined | DefinitionElementProps | A user-assigned label for this element. |
Defined in
- core/common/src/ViewProps.ts Line 146
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.