ViewStore.ReadMethods Interface
methods of cloud ViewDb
for read access
Extends
Implemented by
Methods
Name | Description | |
---|---|---|
getCategorySelectorSync(args: ViewStoreRpc.NameOrId & ViewStoreRpc.QueryBindings): CategorySelectorProps | ||
getDisplayStyleSync(args: ViewStoreRpc.NameOrId & { opts?: DisplayStyleLoadProps }): DisplayStyleProps | ||
getModelSelectorSync(args: ViewStoreRpc.NameOrId & ViewStoreRpc.QueryBindings): ModelSelectorProps | ||
getThumbnailSync(args: { viewId: string }): undefined | ThumbnailProps | ||
getViewByNameSync(arg: { groupId?: number, name: string }): undefined | ViewStoreRpc.ViewInfo | ||
getViewDefinitionSync(args: { viewId: string }): ViewDefinitionProps | ||
queryViewsSync(queryParams: ViewStoreRpc.QueryParams): ViewStoreRpc.ViewInfo[] |
Defined in
- core/backend/src/ViewStore.ts Line 1375
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.