ViewStoreRpc.ViewInfo Interface
Information about a View in a ViewStore.
Properties
Name |
Type |
Description |
|
categorySelectorId |
string |
The Id of the CategorySelector for this view. |
|
className |
string |
The className of the view. |
|
displayStyleId |
string |
The Id of a DisplayStyle for the view. |
|
groupId |
string |
The Id of the view group containing the view. |
|
id |
string |
The Id of the view. |
|
isPrivate |
boolean |
If true, the view is private (unshared) and will only be returned by queries that specify the owner's name. |
|
modelSelectorId |
string | undefined |
The Id of a ModelSelector, if the view has one. |
|
name |
string | undefined |
The name of the view. |
|
owner |
string | undefined |
The name of the owner of the view. |
|
tags |
string[] | undefined |
a list of tags for the view. |
|
Defined in
Last Updated: 14 November, 2024