ViewStoreRpc.QueryParams Interface
Parameters for querying for views in a ViewStore.
Properties
Name | Type | Description | |
---|---|---|---|
classNames Readonly | string[] | undefined | a list of classFullNames to accept. | |
group Readonly | string | undefined | ||
limit Readonly | number | undefined | Optional "LIMIT" clause to limit the number of views returned. | |
nameCompare Readonly | "GLOB" | "LIKE" | "NOT GLOB" | "NOT LIKE" | "=" | "<" | ">" | The comparison operator for nameSearch . |
|
nameSearch Readonly | string | undefined | A string to filter view names. | |
offset Readonly | number | undefined | Optional "OFFSET" clause. | |
owner Readonly | string | undefined | ||
tags Readonly | string[] | undefined | A list of tags to filter views. |
Defined in
- core/common/src/ViewProps.ts Line 296
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.