ViewStoreRpc.Reader Interface
Methods for reading from a ViewStore via Rpc from a frontend via IModelConnection.views.viewsStoreReader
. These
methods use the current ViewStore for the iModel, and attempt to load the default ViewStore if no ViewStore is
currently loaded. They will throw exceptions if the request cannot be fulfilled.
@note The user's accessToken is validated against the ViewStore for every request. For each of these methods, the user only needs read permission to the ViewStore.
Methods
Name | Description | |
---|---|---|
findViewsByOwner(args: { owner: string }): Promise<ViewStoreRpc.ViewInfo[]> | Find all views owned by the supplied owner name. | |
getCategorySelector(args: ViewStoreRpc.NameOrId & ViewStoreRpc.QueryBindings): Promise<CategorySelectorProps> | Get a category selector by Id. | |
getDisplayStyle(args: ViewStoreRpc.NameOrId & { opts?: DisplayStyleLoadProps }): Promise<DisplayStyleProps> | Get a display style by Id. | |
getModelSelector(args: ViewStoreRpc.NameOrId & ViewStoreRpc.QueryBindings): Promise<ModelSelectorProps> | Get a model selector by Id. | |
getThumbnail(args: { viewId: string }): Promise<undefined | ThumbnailProps> | Get a thumbnail for a view. | |
getTimeline(args: ViewStoreRpc.NameOrId): Promise<RenderTimelineProps> | Get a render timeline by Id. | |
getViewByName(arg: { groupId?: string, name: string }): Promise<undefined | ViewStoreRpc.ViewInfo> | Get a view by name. | |
getViewDefinition(args: { viewId: string }): Promise<ViewDefinitionProps> | Get a view definition by viewId. | |
getViewGroupInfo(args: { groupId?: string }): Promise<undefined | ViewStoreRpc.ViewGroupInfo> | get the properties of a ViewGroup by id. | |
getViewGroups(args: { parent?: string }): Promise<{ id: string, name: string }[]> | Get a list of ViewGroups that are children of the supplied parent. | |
getViewInfo(args: { viewId: string }): Promise<undefined | ViewStoreRpc.ViewInfo> | Get the ViewInfo for a view by Id. | |
queryViews(queryParams: ViewStoreRpc.QueryParams): Promise<ViewStoreRpc.ViewInfo[]> | Query for a list of ViewInfos for views that match the supplied QueryParams. |
Defined in
- core/common/src/ViewProps.ts Line 441
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.