RoleModel Class
A container for persisting role elements.
Extends
Extended by
Methods
Name | Description | |
---|---|---|
constructor(props: ModelProps, iModel: IModelDb): RoleModel Protected |
Inherited methods
Name | Inherited from | Description |
---|---|---|
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected | Model | Collect the Ids of this entity's references at this level of the class hierarchy. |
delete(): void | Model | Delete this Model from the iModel. |
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void | Model | Call a function for each property of this Entity. |
getJsonProperty(name: string): any | Model | |
getReferenceIds(): EntityReferenceSet | Model | Get the set of this entity's entity references, EntityReferenceSet. |
getUserProperties(namespace: string): any | Model | Get a set of JSON user properties by namespace |
insert(): string | Model | Insert this Model in the iModel |
removeUserProperties(nameSpace: string): void | Model | Remove a set of JSON user properties, specified by namespace, from this Element |
setJsonProperty(name: string, value: any): void | Model | |
setUserProperties(nameSpace: string, value: any): void | Model | Change a set of user JSON properties of this Element by namespace. |
toJSON(): ModelProps | Model | Obtain the JSON representation of this Entity. |
update(): void | Model | Update this Model in the iModel. |
is(otherClass: ): boolean Static | Model | return whether this Entity class is a subclass of another Entity class |
onDelete(arg: OnModelIdArg): void Protected Static | Model | Called before a Model is deleted. |
onDeleteElement(_arg: OnElementInModelIdArg): void Protected Static | Model | Called when an Element in an instance of a Model of this class is about to be deleted. |
onDeleted(_arg: OnModelIdArg): void Protected Static | Model | Called after a Model was deleted. |
onDeletedElement(_arg: OnElementInModelIdArg): void Protected Static | Model | Called after an Element in an instance of a Model of this class has been deleted. |
onInsert(arg: OnModelPropsArg): void Protected Static | Model | Called before a new Model is inserted. |
onInsertElement(_arg: OnElementInModelPropsArg): void Protected Static | Model | Called before a prospective Element is to be inserted into an instance of a Model of this class. |
onInserted(_arg: OnModelIdArg): void Protected Static | Model | Called after a new Model is inserted. |
onInsertedElement(_arg: OnElementInModelIdArg): void Protected Static | Model | Called after an Element has been inserted into an instance of a Model of this class. |
onUpdate(arg: OnModelPropsArg): void Protected Static | Model | Called before a Model is updated. |
onUpdateElement(_arg: OnElementInModelPropsArg): void Protected Static | Model | Called when an Element in an instance of a Model of this class is about to be updated. |
onUpdated(_arg: OnModelIdArg): void Protected Static | Model | Called after a Model is updated. |
onUpdatedElement(_arg: OnElementInModelIdArg): void Protected Static | Model | Called after an Element in an instance of a Model of this class has been updated. |
Properties
Name | Type | Description | |
---|---|---|---|
className Accessor Static ReadOnly | string | The name of the BIS class associated with this class. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor ReadOnly | string | Model | Get the full BIS class name of this Entity in the form "schema:class". |
classFullName Accessor Static ReadOnly | string | Model | Get the full BIS class name of this Entity in the form "schema:class" |
className Accessor ReadOnly | string | Model | The name of the BIS class associated with this class. |
id | string | Model | The Id of this Entity. |
iModel | IModelDb | Model | The IModelDb that contains this Entity |
isInstanceOfEntity Readonly | "true" | Model | An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types |
isPrivate | boolean | Model | |
isTemplate | boolean | Model | |
jsonProperties Readonly | [key: string]: any | Model | |
modeledElement Readonly | RelatedElement | Model | |
name Readonly | string | Model | |
parentModel Readonly | string | Model | |
schema Static | Model | The Schema that defines this class. | |
schemaName Accessor ReadOnly | string | Model | The name of the BIS Schema that defines this class |
Defined in
- core/backend/src/Model.ts Line 421
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.