FunctionalModel Class

A container for persisting FunctionalElements.

Extends

Methods

Name Description
constructor(props: ModelProps, iModel: IModelDb): FunctionalModel    
insert(iModelDb: IModelDb, parentSubjectId: string, name: string): string Static Insert a FunctionalPartition and a FunctionalModel that breaks it down.  

Inherited methods

Name Inherited from Description
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected Inherited RoleModel Collect the Ids of this entity's references at this level of the class hierarchy.
delete(): void Inherited RoleModel Delete this Model from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited RoleModel Call a function for each property of this Entity.
getJsonProperty(name: string): any Inherited RoleModel  
getReferenceIds(): EntityReferenceSet Inherited RoleModel Get the set of this entity's entity references, EntityReferenceSet.
getUserProperties(namespace: string): any Inherited RoleModel Get a set of JSON user properties by namespace
insert(): string Inherited RoleModel Insert this Model in the iModel
removeUserProperties(nameSpace: string): void Inherited RoleModel Remove a set of JSON user properties, specified by namespace, from this Element
setJsonProperty(name: string, value: any): void Inherited RoleModel  
setUserProperties(nameSpace: string, value: any): void Inherited RoleModel Change a set of user JSON properties of this Element by namespace.
toJSON(): ModelProps Inherited RoleModel Obtain the JSON representation of this Entity.
update(): void Inherited RoleModel Update this Model in the iModel.
is(otherClass: ): boolean Static Inherited RoleModel return whether this Entity class is a subclass of another Entity class
onDelete(arg: OnModelIdArg): void Protected Static Inherited RoleModel Called before a Model is deleted.
onDeleted(_arg: OnModelIdArg): void Protected Static Inherited RoleModel Called after a Model was deleted.
onDeletedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited RoleModel Called after an Element in an instance of a Model of this class has been deleted.
onDeleteElement(_arg: OnElementInModelIdArg): void Protected Static Inherited RoleModel Called when an Element in an instance of a Model of this class is about to be deleted.
onInsert(arg: OnModelPropsArg): void Protected Static Inherited RoleModel Called before a new Model is inserted.
onInserted(_arg: OnModelIdArg): void Protected Static Inherited RoleModel Called after a new Model is inserted.
onInsertedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited RoleModel Called after an Element has been inserted into an instance of a Model of this class.
onInsertElement(_arg: OnElementInModelPropsArg): void Protected Static Inherited RoleModel Called before a prospective Element is to be inserted into an instance of a Model of this class.
onUpdate(arg: OnModelPropsArg): void Protected Static Inherited RoleModel Called before a Model is updated.
onUpdated(_arg: OnModelIdArg): void Protected Static Inherited RoleModel Called after a Model is updated.
onUpdatedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited RoleModel Called after an Element in an instance of a Model of this class has been updated.
onUpdateElement(_arg: OnElementInModelPropsArg): void Protected Static Inherited RoleModel Called when an Element in an instance of a Model of this class is about to be updated.

Properties

Name Type Description
className Accessor Static ReadOnly string The name of the BIS class associated with this class.  

Inherited properties

Name Type Inherited from Description
classFullName Accessor Inherited ReadOnly string RoleModel Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor Static Inherited ReadOnly string RoleModel Get the full BIS class name of this Entity in the form "schema:class"
className Accessor Inherited ReadOnly string RoleModel The name of the BIS class associated with this class.
id Inherited string RoleModel The Id of this Entity.
iModel Inherited IModelDb RoleModel The IModelDb that contains this Entity
isInstanceOfEntity Readonly Inherited "true" RoleModel An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
isPrivate Inherited boolean RoleModel  
isTemplate Inherited boolean RoleModel  
jsonProperties Readonly Inherited { T } RoleModel  
modeledElement Readonly Inherited RelatedElement RoleModel  
name Readonly Inherited string RoleModel  
parentModel Readonly Inherited string RoleModel  
schema Static Inherited RoleModel The Schema that defines this class.
schemaName Accessor Inherited ReadOnly string RoleModel The name of the BIS Schema that defines this class

Defined in

Last Updated: 14 November, 2024