PresentationRpcInterface Class
Interface used for communication between Presentation backend and frontend.
Extends
Methods
Name |
Description |
|
constructor(routing?: RpcRoutingToken): PresentationRpcInterface |
|
|
computeSelection(_token: IModelRpcProps, _options: SelectionScopeRpcRequestOptions, _ids: string[], _scopeId: string): PresentationRpcResponse<KeySetJSON> |
|
Deprecated |
computeSelection(_token: IModelRpcProps, _options: ComputeSelectionRpcRequestOptions): PresentationRpcResponse<KeySetJSON> |
|
Deprecated |
getContentDescriptor(_token: IModelRpcProps, _options: ContentDescriptorRpcRequestOptions): PresentationRpcResponse<undefined | DescriptorJSON> |
|
Deprecated |
getContentInstanceKeys(_token: IModelRpcProps, _options: ContentInstanceKeysRpcRequestOptions): PresentationRpcResponse<{ items: KeySetJSON, total: number }> |
|
Deprecated |
getContentSetSize(_token: IModelRpcProps, _options: ContentRpcRequestOptions): PresentationRpcResponse<number> |
|
Deprecated |
getContentSources(_token: IModelRpcProps, _options: ContentSourcesRpcRequestOptions): PresentationRpcResponse<ContentSourcesRpcResult> |
|
Deprecated |
getDisplayLabelDefinition(_token: IModelRpcProps, _options: DisplayLabelRpcRequestOptions): PresentationRpcResponse<LabelDefinition> |
|
Deprecated |
getElementProperties(_token: IModelRpcProps, _options: SingleElementPropertiesRpcRequestOptions): PresentationRpcResponse<undefined | ElementProperties> |
|
Deprecated |
getFilteredNodePaths(_token: IModelRpcProps, _options: FilterByTextHierarchyRpcRequestOptions): PresentationRpcResponse<NodePathElementJSON[]> |
|
Deprecated |
getNodePaths(_token: IModelRpcProps, _options: FilterByInstancePathsHierarchyRpcRequestOptions): PresentationRpcResponse<NodePathElementJSON[]> |
|
Deprecated |
getNodesCount(_token: IModelRpcProps, _options: HierarchyRpcRequestOptions): PresentationRpcResponse<number> |
|
Deprecated |
getNodesDescriptor(_token: IModelRpcProps, _options: HierarchyLevelDescriptorRpcRequestOptions): PresentationRpcResponse<undefined | string | DescriptorJSON> |
|
Deprecated |
getPagedContent(_token: IModelRpcProps, _options: Paged<ContentRpcRequestOptions>): PresentationRpcResponse<undefined | { contentSet: PagedResponse<ItemJSON>, descriptor: DescriptorJSON }> |
|
Deprecated |
getPagedContentSet(_token: IModelRpcProps, _options: Paged<ContentRpcRequestOptions>): PresentationRpcResponse<PagedResponse<ItemJSON>> |
|
Deprecated |
getPagedDisplayLabelDefinitions(_token: IModelRpcProps, _options: DisplayLabelsRpcRequestOptions): PresentationRpcResponse<PagedResponse<LabelDefinition>> |
|
Deprecated |
getPagedDistinctValues(_token: IModelRpcProps, _options: DistinctValuesRpcRequestOptions): PresentationRpcResponse<PagedResponse<DisplayValueGroupJSON>> |
|
Deprecated |
getPagedNodes(_token: IModelRpcProps, _options: Paged<HierarchyRpcRequestOptions>): PresentationRpcResponse<PagedResponse<NodeJSON>> |
|
Deprecated |
getSelectionScopes(_token: IModelRpcProps, _options: SelectionScopeRpcRequestOptions): PresentationRpcResponse<SelectionScope[]> |
|
Deprecated |
Inherited methods
Name |
Inherited from |
Description |
forward<T>(parameters: IArguments): Promise<T> |
RpcInterface |
Obtains the implementation result for an RPC operation. |
isVersionCompatible(backend: string, frontend: string): boolean Static |
RpcInterface |
Determines whether the backend version of an RPC interface is compatible (according to semantic versioning) with the frontend version of the interface. |
Properties
Name |
Type |
Description |
|
interfaceName Static Readonly |
"PresentationRpcInterface" |
The immutable name of the interface. |
|
interfaceVersion Static |
string |
The semantic version of the interface. |
|
Defined in
Last Updated: 13 November, 2024