NodeJSON Interface
Deprecated in 3.x. Use Node.
Serialized Node JSON representation.
Properties
Name | Type | Description | |
---|---|---|---|
backColor | string | undefined | Deprecated | |
description | string | undefined | ||
extendedData | { T } | undefined | ||
fontStyle | string | undefined | Deprecated | |
foreColor | string | undefined | Deprecated | |
hasChildren | boolean | undefined | ||
imageId | string | undefined | Deprecated | |
isCheckboxEnabled | boolean | undefined | Deprecated | |
isCheckboxVisible | boolean | undefined | Deprecated | |
isChecked | boolean | undefined | Deprecated | |
isEditable | boolean | undefined | ||
isExpanded | boolean | undefined | ||
isSelectionDisabled | boolean | undefined | ||
key | NodeKeyJSON | ||
labelDefinition | LabelDefinitionJSON | ||
supportsFiltering | boolean | undefined |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.